DVBLink for IPTV is discussed here!


Postby jasonwilliams » Sun Nov 12, 2017 6:44 pm

Hi there,

Just downloaded the trial and I'm setting up my TVXML source, but after adding the URL, it has an icon that says:  "Not Configured" and the EPG doesn't download.  I've tried several different sources:


As well as the URLs provided by my IPTV provider (NecroIPTV).  The only thing I see in the logs is:

[12/Nov/2017:12:08:18] DVB.CMN.SR Add source XMLTV1.
[12/Nov/2017:12:08:19] DVB.XMLTV.ST Get settings: XMLTV1.
[12/Nov/2017:12:08:19] DVB.SCFG.ST Create configurator "XMLTV1".
[12/Nov/2017:12:08:36] DVB.XMLTV.ST Save xmltv "XMLTV1" (u'C:\\ProgramData\\DVBLogic\\DVBLink\\xmltv', u'12', u'[{"url":"http://watch.necroiptv.com/xmltv.php?username=XXXXXXXX&password=XXXXXXX","type":"0","id":"2"}]').
[12/Nov/2017:12:08:36] DVB.SCFG.ST Cleanup source "XMLTV1".
[12/Nov/2017:12:08:36] DVB.SCFG.ST Cleanup Ok.
[12/Nov/2017:12:08:36] DVB.CMN.SR load sources.
[12/Nov/2017:12:08:36] DVB.CMN.SR Available templates: 3,  sources 2.
[12/Nov/2017:12:08:47] DVB.CMN.MG Start monitoring.
[12/Nov/2017:12:08:51] DVB.CMN.SSG Start general settings.
[12/Nov/2017:12:09:00] DVB.CMN.SSG Save log archive.

(*note that I changed the username & password to XXXXXs for this post).  There are no special characters in the actual password.

I have DVBLink Server build 14499 and IPTV version 6.0.0 build 13107.

Any help is much appreciated!
Posts: 10
Joined: Sat Feb 13, 2010 1:30 am


Postby jussistev » Thu Dec 07, 2017 1:08 pm

I have same problem.

Is dvblogic really not helping us ? Its good i not bought that after tested just iptv, bc i prety much wanted already buy dvblocig iptv after saw that i can record with KODI and Dvblocig IPTV, but after tried xmltv i already start get mad for that program...

I tried 3 days already get that xmltv work, leted wait even 10hours to load xmtlv epg but its niot loaded still.

I puted files in programdata dvblink xmltv folder and also i have xml files in website, for xmltv crabber but nothingwork, its just not loading.

Can someone helpo me get that work ? I can even give teamviewer access if you guys really can help me. IF you cnt, then please say.. i already worked 3 day with that and pointless to wait or try more, if you guys will not help me..

Posts: 1
Joined: Thu Dec 07, 2017 1:01 pm


Postby BrewskyAZ » Tue Dec 12, 2017 4:50 am

I was able to get the "Not Configured" to go away. I use an online IPTV service, they provide me an EPG link. I added that link, as you did, in the DVBLink application, but nothing. Waited and waited, but nothing. I did a little research and found you need to add an XML file in (windows: C:\ProgramData\DVBLogic\DVBLink\xmltv) folder.

Since I have a link from my provider, I entered that into a web browser. It gave me the XML text in the browser. I had to copy and paste that into a new file called: xmltv.xml

I deleted and recreated my EPG entry, and it showed good, no more "Not Configured". I was able to add the EPG to the channels in Channels->EPG Sources.

Now, I am not sure if the system will download from my provider or not, but at least I am no longer getting the "Not Configured"

Good luck. If you find more info, please let us know.
Posts: 12
Joined: Tue Dec 12, 2017 4:25 am

Return to DVBLink for IPTV

Who is online

Users browsing this forum: No registered users and 2 guests