EPG Guide not showing on clients

DVBLink Connect! Server is discussed here!

EPG Guide not showing on clients

Postby BryanDeNijs » Mon Mar 19, 2012 4:41 pm

Hello,

Yesterday I succesfully installed DVBLink Server, TVSource and Connect! Server.
As far as I know, I have everything set up properly.
On my DVBLink Clients (Android, IPad and Windows Media Center), I can watch TV and everything works fine, except for the EPG Guide.
The Programguide is empty on all the clients. First I thought that it was a matter of time, but after a day waiting, nothing has happened.

If I open the file "C:\Program Files(x86)\DVBLogic\DVBLink\sources\TVTuner\epg\eitscanner_epg.xml", there is a actual program guide in it.
Knowing this, I can conclude that TVSource gets the EPG data but Connect! Server doesn't give it to the clients.

What have I done wrong and how can I solve this problem?
BryanDeNijs
 
Posts: 7
Joined: Mon Mar 19, 2012 1:01 pm


Re: EPG Guide not showing on clients

Postby Oberon » Mon Mar 19, 2012 4:44 pm

Have you mapped epg channels to your tv channels on the EPG sources tab of the dvblink web configurator?
Server: Synology DS212j, TBS5980CI (Dutch CanalDigitaal), TeVii s660 unicable Astra 28.2E, DVBLink TVSource 4.6.0, all DVBLink EPG Loaders
Clients: AsRock ION 330 Win7 MediaCenter, Samsung DLNA TV, IPad, Samsung Galaxy S, Nexus 7
Oberon
 
Posts: 7152
Joined: Thu Sep 06, 2007 5:04 am

Re: EPG Guide not showing on clients

Postby BryanDeNijs » Mon Mar 19, 2012 4:50 pm

Oberon wrote:Have you mapped epg channels to your tv channels on the EPG sources tab of the dvblink web configurator?

Yes I have done that.
BryanDeNijs
 
Posts: 7
Joined: Mon Mar 19, 2012 1:01 pm

Re: EPG Guide not showing on clients

Postby BryanDeNijs » Wed Mar 21, 2012 5:00 pm

Hmmm, no answer.

It's still not working. Yes I have mapped the right EPG channels on the EPG Sources tab and yes I have scanned to EPG etc, but still no luck.
What could it be?
BryanDeNijs
 
Posts: 7
Joined: Mon Mar 19, 2012 1:01 pm

Re: EPG Guide not showing on clients

Postby Oberon » Wed Mar 21, 2012 5:08 pm

Difficult to say. It sounds like a brute force, but maybe you need to delete MediaCenter database and redo TV Setup afterwards.
Server: Synology DS212j, TBS5980CI (Dutch CanalDigitaal), TeVii s660 unicable Astra 28.2E, DVBLink TVSource 4.6.0, all DVBLink EPG Loaders
Clients: AsRock ION 330 Win7 MediaCenter, Samsung DLNA TV, IPad, Samsung Galaxy S, Nexus 7
Oberon
 
Posts: 7152
Joined: Thu Sep 06, 2007 5:04 am

Re: EPG Guide not showing on clients

Postby politby » Thu Mar 22, 2012 8:33 am

I just completed setup of a new server yesterday and I am seeing the exact same problem. No EPG information makes it to the client.
Already tried the reset of the MC database several times. No data.

EIT scan appears to work fine and results in a nicely formatted xml file. All four tuners are configured in Media Center, etc. and the EPG source setup ran without a hitch matching all the channels.

I have this working fine with 4.1.1 on my home system where the server and Media Center are on the same machine so this problem appears to affect network client/server scenarios only.

Because this is a new install, I cannot tell if this also means channel sync is not working, as many others have pointed out, but the initial TV setup found all the channels and the actual TV functionality seems fine. Is the channel sync and EPG load part of the same process or are they separate?

Any logging I can activate to trace this? I can see nothing in any of the default log files.

This is, if not a deal breaker, infuriating.

Sent from my GT-P7500 using Tapatalk
politby
 
Posts: 93
Joined: Tue May 05, 2009 1:29 pm

Re: EPG Guide not showing on clients

Postby BryanDeNijs » Thu Mar 22, 2012 10:23 am

Glad to read I am not the only one with this problem

@oberon What does brute forece has to do with this problem? As far as I know, brute force is a whole other topic.
Due to technical problems with my machine, I can't test if redoing the TV setup will help right now.
I hope these technical problems on my machine will be solved so I can try to 'repair' DVBLogic again.

@politby If you mean Channel Sync is the synchronization when you edit some TV Channels on the server, that these will automatically update on the client, then I can say that this works for me. Only the EPG is a problem.
BryanDeNijs
 
Posts: 7
Joined: Mon Mar 19, 2012 1:01 pm

EPG Guide not showing on clients

Postby politby » Sun Mar 25, 2012 7:59 am

I think I have found the cause of the problem in my case. At some point Media Center had tried to download TV/guide information and failed because the Internet link was down.
This caused the "download of the latest setup information for your region" to fail when I did a new TV setup after clearing the TV database. I then tried a manual dowload from the MC menu, which also failed and told me it could not be done because of previous failed download attempts.

I think this stops 7MC from loading the EPG data from the DVBlink server, and possibly the channel sync as well.

Yesterday I added a completely new client to the network and it worked without a hitch. From which I conclude that this is a client side problem and that just deleting the TV database files from the programdata\microsoft\ehome directory won't fix it. MediaCenter needs to be completely reset to a post-Windows-install state. Not sure how to do that so I will wipe the offending client and re-image it from the fresh client I installed yesterday.

Hope this helps


---
I am here: http://tapatalk.com/map.php?bbk12v
politby
 
Posts: 93
Joined: Tue May 05, 2009 1:29 pm


Return to DVBLink Connect! Server

Who is online

Users browsing this forum: No registered users and 3 guests