TVAdviser (GB) - Installation Error

Discuss DVBLink on Raspberry Pi platform here!

TVAdviser (GB) - Installation Error

Postby paul608085 » Sat May 14, 2016 2:38 pm

I have an existing DVBLink TVServer built on a Netgear ReadyNAS104. I am currently testing TVServer on a RaspberryPi 3, (trial licence), and I am planning to purchase the RPi version of TVServer and move over to it, (much faster than ReadyNAS).

Before I transfer, a couple of questions:

1.) I have tried to install TVAdviser (GB) on this trial system but keep getting an "Installation Error" - is this because I am using a trial licence, or does TVAdviser not work on Raspberry Pi?

2.) I have quite a long time to go on my existing Netgear TVAdviser subscription, (9 months?). Is it possible to transfer the subscription from the Netgear system to the Raspberry Pi?

TIA

Paul
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am


Re: TVAdviser (GB) - Installation Error

Postby the_man » Mon May 16, 2016 10:07 am

#1 Need to check the log files.
Please set log level to info, restart DVBLink server, reproduce the issue, download and attach zipped DVBLink log files to this ticket.
Information on how to set log level and download log files can be found on the Wiki:
http://dvblogic.com/wiki/index.php/How_ ... _log_files

Also, you can try to download and manually install the TVAdviser*.dlp file form the Downloads page on the dvblogic.com

#2 Yes it is possible for the subscription. Just write to the info@dvbloc.com about it.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: TVAdviser (GB) - Installation Error

Postby paul608085 » Mon May 16, 2016 10:31 am

I have set the log to Info, restarted and reproduced the problem. Log is attached.

Regards,

Paul
Attachments
dvblink-log-20160516-1029.zip
Log after failing to install TVAdviser
(40.99 KiB) Downloaded 132 times
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am

Re: TVAdviser (GB) - Installation Error

Postby paul608085 » Mon May 16, 2016 10:39 am

I download the dvblink-tvadviser_gb-raspberry-linux-arm-5.5.0.dlp file and manually installing it: same error message. Latest log attached.

Regards,

Paul
Attachments
dvblink-log-20160516-1039.zip
Log after failing to install TVAdviser manually.
(54.71 KiB) Downloaded 132 times
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am

Re: TVAdviser (GB) - Installation Error

Postby the_man » Mon May 16, 2016 11:09 am

Try to reboot the RPI, then make a repair of the TVSource, and try to install the TVAdviser once more.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: TVAdviser (GB) - Installation Error

Postby paul608085 » Mon May 16, 2016 11:19 am

I restarted the RPi and tried to repair TVSource via Products > DVBLink Package Center. I got the same "Installation Error" message.

Log is attached.
Attachments
dvblink-log-20160516-1117.zip
Failed to repair TVSource
(46.15 KiB) Downloaded 129 times
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am

Re: TVAdviser (GB) - Installation Error

Postby the_man » Mon May 16, 2016 11:22 am

Try to make an update of the DVBlink Server.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: TVAdviser (GB) - Installation Error

Postby paul608085 » Mon May 16, 2016 11:32 am

How do I update TVServer? I have installed build 5.5.0 and that is the version on dvblogic.com
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am

Re: TVAdviser (GB) - Installation Error

Postby the_man » Mon May 16, 2016 11:44 am

Just install the server over the current one. Or better maker a backup of DVBLink settings
http://dvblogic.com/wiki/index.php/How_ ... nd_restore
Then remove the DVBLink server folder and install the new server from scratch.
Install needed packages and restore the settings from the backup file.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: TVAdviser (GB) - Installation Error

Postby paul608085 » Mon May 16, 2016 2:44 pm

That was harder than I had hoped :( :

I was able to back up DVBLink, remove it and delete the folder in /opt. However, even a fresh download of TVServer failed to install. I also noticed before un-installing that there was some other erratic behaviour such as no longer being able to go straight to the setup page on port 39876, but having to go via the TV Guide on 8100 first every time.

I thought that the microSD card may have become corrupted so I wiped it and re-installed the Pi OS and DVBLink. It seems to be working OK now and I have been able install TVAdviser from the Package Centre. I'm just waiting for DVBLogic to transfer the subscription from my ReadyNAS.

Paul
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am

Re: TVAdviser (GB) - Installation Error

Postby paul608085 » Thu May 19, 2016 12:06 am

Apologies for the delay in following this up: after many aborted attempts at getting this working in a stable way it appears that the microSD card I was using for the OS and DVBLink was damaged - it was doing some very strange things!

Anyway, one new microSD card later and everything seems to be working well: I can thoroughly recommend the Raspberry Pi 3 as the basis for a DVBLink setup. I have more than 200 channels in my list - on the Netgear ReadyNAS104 it took over two minutes for the EPG to load before I could do anything, with the RaspberryPi set-up this is now around 20 seconds!

Thanks for your help earlier.

Regards,

Paul
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am

Re: TVAdviser (GB) - Installation Error

Postby the_man » Thu May 19, 2016 8:22 am

paul608085 wrote:Apologies for the delay in following this up: after many aborted attempts at getting this working in a stable way it appears that the microSD card I was using for the OS and DVBLink was damaged - it was doing some very strange things!

Anyway, one new microSD card later and everything seems to be working well: I can thoroughly recommend the Raspberry Pi 3 as the basis for a DVBLink setup. I have more than 200 channels in my list - on the Netgear ReadyNAS104 it took over two minutes for the EPG to load before I could do anything, with the RaspberryPi set-up this is now around 20 seconds!

Thanks for your help earlier.

Regards,

Paul

Thank you for your feedback.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: TVAdviser (GB) - Installation Error

Postby paul608085 » Thu May 19, 2016 3:30 pm

UPDATE

I might have been a bit premature in my praise of the RaspberryPi 3 :(

It may be just my system - when it works it is great, however stability of the PI OS or board, (DVBLink software seems to be fine), is an issue for me. At first I thought that I had a dodgy memory card, now I'm not certain that the board itself may not be faulty. I spent most of last night and today trying to get this to work reliably. At the moment it will no longer connect to the network. Another fresh install of the OS may resolve this, but I've spent enough time on this and I'm planning to go back to the slow, but reliable, ReadyNAS.

Regards

Paul
paul608085
 
Posts: 43
Joined: Mon Jul 27, 2015 10:56 am


Return to DVBLink TV Server for Raspberry Pi

Who is online

Users browsing this forum: No registered users and 5 guests

cron