After NAS restore: DVBLink not working anymore

DVBLink TV Server for QNAP NAS is discussed here!

After NAS restore: DVBLink not working anymore

Postby Master of Tragedy » Tue Dec 29, 2015 11:55 am

Because of some issues with my NAS I had to restore everything from a backup.
I also backed up the complete DVBLink-directory and restored it after I installed the DVBLink qpkg again.
But it seems it didn't quite work out and I still had to setup everything again from scratch.
I have done that now, all channels are configured but when I try to access the web page with the channel list it just shows a dialog box with "general error" and no channels are shown.
Also I can't activate DVBLink TVSource anymore. When I try to activate it it just shows "already activated" but remains deactivated.
I have requested a new registration yesterday but got nothing so far and used the trial period for now.

Is there any way I can install DVBLink again properly and just copy my old configuration back? I mean, I have everything here in my backup but obviously just copying the whole directory is too much. I just want my old channels, my recordings and my general configuration and my activated DVBLink TVSource.
Attachments
dvblink-log-20151229-1159.zip
(13.68 KiB) Downloaded 145 times
Master of Tragedy
 
Posts: 46
Joined: Thu May 29, 2014 7:18 pm


Re: After NAS restore: DVBLink not working anymore

Postby the_man » Tue Dec 29, 2015 12:05 pm

As for licenses, you can try to download the *.lic file at you dvblogic license portal: https://license.dvblogic.com/
After that stop dvblink, go to /DVBLink/share/licenses/ and put there the lic file you've just downloaded. After that start dvblink server, and check if your TVSource is activated now.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: After NAS restore: DVBLink not working anymore

Postby the_man » Tue Dec 29, 2015 12:11 pm

To save and then restore dvblink configuration you have to use the previously made Backup file (file with all configuration, you have already done: scanning, channels selection ...)
http://dvblogic.com/wiki/index.php/How_ ... nd_restore
So, i do not know if it will work with copying the full dvblink folder.

Anyway set log level to info, restart dvblink server, wait up to 20 minutes and attach zipped log file here.
Also check whether there at the RecordedTV Tab your recordings?
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: After NAS restore: DVBLink not working anymore

Postby Master of Tragedy » Tue Dec 29, 2015 1:19 pm

Ok, the license issue is solved now after I copied the file to the licenses directory.
The rest doesn't work.
My log-file was already attached to the first post.

I had previously changed the directory where recordings are saved. I changed it back to that directory but it doesn't seem to do anything. It still shows no entry found.
Master of Tragedy
 
Posts: 46
Joined: Thu May 29, 2014 7:18 pm

Re: After NAS restore: DVBLink not working anymore

Postby the_man » Tue Dec 29, 2015 1:22 pm

Are there ts files (recordings) physically in the RecordedTV folder?
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: After NAS restore: DVBLink not working anymore

Postby Master of Tragedy » Tue Dec 29, 2015 1:26 pm

Yes, there are.
Master of Tragedy
 
Posts: 46
Joined: Thu May 29, 2014 7:18 pm

Re: After NAS restore: DVBLink not working anymore

Postby the_man » Tue Dec 29, 2015 1:32 pm

Ok, Please, make a new log file as i've requested earlier.
Maybe it is just a corruption in dlrecorder.db file.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: After NAS restore: DVBLink not working anymore

Postby Master of Tragedy » Tue Dec 29, 2015 2:59 pm

Here's the log.
I just started DVBLink again, waited for an hour or so and tried to access the channels webpage and then the recordings page afterwards.
Attachments
dvblink-log-20151229-1458.zip
(36.24 KiB) Downloaded 137 times
Master of Tragedy
 
Posts: 46
Joined: Thu May 29, 2014 7:18 pm

Re: After NAS restore: DVBLink not working anymore

Postby the_man » Tue Dec 29, 2015 3:02 pm

Yes, seems the dlrecorded.db is corrupted.
You can repair it by following this manual:
http://dvblogic.com/wiki/index.php/How_ ... er.db_file
Or i can do it for you.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: After NAS restore: DVBLink not working anymore

Postby Master of Tragedy » Tue Dec 29, 2015 3:28 pm

Would be cool if you can do it for me.
I only have a Macbook and the instructions are for windows machines.

But what about the channels and the general error that appears without showing ANY channels?
That is the even bigger issue.
Master of Tragedy
 
Posts: 46
Joined: Thu May 29, 2014 7:18 pm

Re: After NAS restore: DVBLink not working anymore

Postby the_man » Tue Dec 29, 2015 3:31 pm

Upload your dlrecorder.db file to any of file sharing and give me a link in PM.
I'll do it tomorrow.
But what about the channels and the general error that appears without showing ANY channels?

Step by step...
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: After NAS restore: DVBLink not working anymore

Postby Master of Tragedy » Tue Dec 29, 2015 3:45 pm

Never mind. Did the steps to rebuild the database myself now as sqlite is built in Mac OS X (I wasn't aware of that).
Hasn't changed a thing though. No recordings are shown.

There is only a table "deleted_recordings" in the database anyway. Isn't there something missing? Like "recordings"?
Master of Tragedy
 
Posts: 46
Joined: Thu May 29, 2014 7:18 pm

Re: After NAS restore: DVBLink not working anymore

Postby the_man » Wed Dec 30, 2015 9:02 am

The info about recordings are in "completed_recording" table. If there is nothing, then you will not be able to get recordings back to the DVBLink (at least in auto mode, the only way, but routine way it's try to add recordings manually )
You can upload your db and i will check it.
Anyway the way you have done a restore is wrong one, and as i understand the only thing you can try to save it's recordings ( if you have a backup of dlrecorder.db it may give more chance to save recordings )
PS. I would like to have a look at your issue via teamviewer, but I'm a quite busy these days, so lets try to continue hearing in "chat mode"
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: After NAS restore: DVBLink not working anymore

Postby Master of Tragedy » Wed Dec 30, 2015 10:00 am

Well, I have a backup of this dlrecorder.db. But even this backup doesn't include the completed_recording table which is strange as it was working fine in the moment the backup was taken.

Ok, I will try to deinstall everything now and try a clean install again to at least get the normal tv working again hopefully.
Then I will take a look at the dlrecorder.db to see if I can get my recordings back somehow.
Master of Tragedy
 
Posts: 46
Joined: Thu May 29, 2014 7:18 pm

Re: After NAS restore: DVBLink not working anymore

Postby the_man » Wed Dec 30, 2015 10:12 am

Try to do next steps:
- do a reinstall of dvblink server
- In the TV and Media Library - > settings -> recorder:
- be sure that the option: "Background check for deleted recordings" is unchecked
- set recordings path that was with the old dlrecorder.db
- stop dvblink server
- replace the current db file with db file from backup
- start dvblink server, check the RecordedTV tab after 5-10 minutes
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Next

Return to DVBLink TV Server for QNAP NAS

Who is online

Users browsing this forum: No registered users and 2 guests

cron