Where has my EPG gone?

DVBLink TV Server for Synology NAS is discussed here!

Where has my EPG gone?

Postby Bart_da_Man » Tue May 23, 2017 9:34 pm

I'm using DVBLink Server 6.0.0 build 14499 and DVBLink for IPTV 6.0.0 build 13109 on Synology 214+.
The TV streams are from Rapid IPTV, it is working fine.
The EPG is from this weblink: http://epg.kodi-forum.nl/tvguide.xml
It has always worked fine, but since the upgrade to build 14499 the guide stays empty.

I have attached the log file (errors and warnings).

I really hope someone can help me restore the EPG, my wife and kids do not like me very much the last couple of days :cry:
Attachments
dvblink-log-20170523-2232.zip
(31.15 KiB) Downloaded 139 times
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm


Re: Where has my EPG gone?

Postby the_man » Wed May 24, 2017 9:50 am

Please, restart the DVBlink server and make a repair of database:
http://dvblogic.com/wiki/index.php/How_ ... :_Recorder
Then wait up to 20 minutes and check the Guide, if there is no EPG data, make a new log files.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Wed May 24, 2017 9:57 pm

Oaky, stopped and started DVBlink server and after that repaired the database.
Alas, no luck still. It's wel after an hour now.

New log attached.
Attachments
dvblink-log-20170524-2251.zip
(32.87 KiB) Downloaded 127 times
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby the_man » Thu May 25, 2017 8:09 am

Looks like you should re-map channels.
Make a backup of current settings:
http://dvblogic.com/wiki/index.php/How_ ... nd_restore

Then go to Channels, and remove all selected channels, Save changes, now select all required channels once more, Save.
Make a new repair of database and wait up to 20 minutes, If EPG is not appear, attach new zipped log files here.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Thu May 25, 2017 10:45 pm

Thanks for the tips. I followed them all, but still alas...
New log attached.
Attachments
dvblink-log-20170525-2343.zip
(33.95 KiB) Downloaded 125 times
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby the_man » Fri May 26, 2017 8:21 am

You have forgot to set log level to info , hence there is not to much information about what is wrong.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Fri May 26, 2017 1:22 pm

Okay.. thought you needed Errors and Warnings log.
Now Exended Info log attached.
Attachments
dvblink-log-20170526-1421.zip
(36.7 KiB) Downloaded 139 times
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby the_man » Tue May 30, 2017 8:21 am

Please, try to download the XML file and put it directly to DVBLink\XMLTV\ folder and then re-create the XMLTVSource.
After a 10 minutes check whether the channels from EPG data is appeared at the Channels -> EPG sources tab, if yes, assign EPG data and check the Guide in a 20 minutes.
New logs then please/
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Wed May 31, 2017 9:59 pm

Hmm, did what you asked, deleted the old epg source and added a new one as follows:
Image

Now I see an exclamation mark that I cannot get rid off:
Image

BTW, I placed tvguide.xml in folder /var/packages/DVBLinkServer/target/share/xmltv

Don't know if new log is of use, but here it is anyway.
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Wed May 31, 2017 10:04 pm

Last edited by Bart_da_Man on Wed May 31, 2017 10:27 pm, edited 1 time in total.
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Wed May 31, 2017 10:06 pm

Huh? I attached log as I did in earlier posts, but it no longer works...?!
How to upload log?
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby the_man » Thu Jun 01, 2017 2:44 pm

Seems your log files is too big to be uploaded.
As for EPG, in the logs i see that your xmltv file consist an EPG data only up to 2017-05-20 and no more. I guess it is a main issue regarding the EPG data. Seems you need updated EPG file, or subscription ...
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Thu Jun 01, 2017 11:30 pm

Okay... new tvguide.xml placed in /var/packages/DVBLinkServer/target/share/xmltv
This guide is from: http://hiptv-epg.ddns.net/epg/tvguide.xml

Made new epg source and assigned right epg source to each channel.

But alas, after >30 min still no luck.

Log file (info only) is 4.8 MB. The max allowed upload size is 256 kB.
Can I reset the log to make it small?
Last edited by Bart_da_Man on Thu Jun 01, 2017 11:32 pm, edited 1 time in total.
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Thu Jun 01, 2017 11:31 pm

Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Re: Where has my EPG gone?

Postby Bart_da_Man » Fri Jun 02, 2017 11:20 pm

Okay, I'm very fed up with DVBLink now.

This is what I did.

Made back-up.
Removed DVBLink Server package from Package manager.
Renamed /volume1\DVBLink to /volume1\DVBLink_old
Restarted Synology

Downloaded latest DVBLink server from DVBLogic website
Manually installed it.
Installed DVBLink for IPTV
Uploaded my license file into /volume1/DVBLink/licenses
Configured everything again and hey! EPG is working again! :D

But then...
Moved all files from /volume1\DVBLink_old\RecordedTV to /volume1\DVBLink\RecordedTV
And restored backup.
EPG is gone again :evil:

So back to the start of this post, did everything again except restoring the backup. And all recording files are still in /volume1\DVBLink_old\RecordedTV.

Is there some way to restore my timers/recording schedules and recordings without destroying the EPG? :roll:
Bart_da_Man
 
Posts: 17
Joined: Sat Jan 04, 2014 1:27 pm

Next

Return to DVBLink TV Server for Synology NAS

Who is online

Users browsing this forum: No registered users and 3 guests

cron