SOLVED-DS213J + HDHomerun HDHR3-US artifacts (discontinuity)

DVBLink TV Server for Synology NAS is discussed here!

SOLVED-DS213J + HDHomerun HDHR3-US artifacts (discontinuity)

Postby mandr » Wed Apr 30, 2014 2:26 am

Hi,

Here is my setup:
* Tried DVBLink 4.7, and I also tried DVBLink 5.0 Beta 1 (hoping that this would be fixed in there)
* Synology DS213J, DSM 5.0-4482 (2014-04-18)
* HDHomerun HDHR3-US, Firmware: 20140405beta1 - connected to an OTA antenna here in Ottawa, Canada (ATSC, MPEG2 HD video, 15 Mbps, AC3 5.1 or 2)
* Router is Linksys E3000 running DD-WRT
-----
* XBMC Frodo 12.3 running on Windows 7 and a Raspberry Pi with Raspbmc XBMC Gotham Beta 4 connected by secondary router Apple Airport Extreme

All the above connections are wired.

1. Trying to record shows gives artifacts on the screen and an ever so slight interruption in the sound. The video keeps rolling though.
2. Watching LiveTV on the Windows 7 using the DVBLink Addon (v1.7) still produces those occasional artifacts and sound interruption
3. Watching LiveTV on the Raspberry Pi using the DVBLink Addon (v1.9) has the same result as above.
4. Watching LiveTV using the .strm file (straight stream from HDHomerun) is flawless in the Windows 7 machine
5. Watching LiveTV using the .strm file (straight stream from HDHomerun) is flawless in the Raspberry Pi

I don't believe it's a networking problem as connecting through 2 routers and using the .strm file plays flawlessly, but with only one router, I get problems. I only get those artifacts when I watch using DVBLink or try to record directly using the DVBLink (accessing the app on Synology). I also used to run NextPVR on Windows and never had artifacts on my HDHomerun signal.

Further Problem Details:

For (2) and (3) in the above list, when monitoring the channel, which for example will have Signal Strength of 77% and Signal Quality of 77%, there are no errors but the discontinuity count always increases, and then resets to 0, and then increases again. This goes on and on. I'm attaching a debug log that was taken when I tried (2). It's towards the bottom that I tried watching LiveTV and get those artifacts.

Any help on how I can fix this would be greatly appreciated as I would LOVE to buy DVBLink on Synology. Once less computer! For now I'm using the Trial version and this bug is all that's holding me up from buying it.
Attachments
dvblink-log-20140429-2054.zip
At the bottom I stopped and watched LiveTV twice
(57.03 KiB) Downloaded 267 times
Last edited by mandr on Fri May 09, 2014 2:17 am, edited 1 time in total.
mandr
 
Posts: 6
Joined: Tue Apr 29, 2014 2:30 am


Re: DS213J + HDHomerun HDHR3-US artifacts (discontinuity)

Postby mandr » Wed Apr 30, 2014 8:17 pm

I tested the DVBLink Android app on my Nexus 5 and I can stream using MX Player just fine. Although the Nexus 5 (and pretty much all phones) don't have hardware acceleration for MPEG-2, it kept up using software decoding.

Still trying to figure out how to get rid of those artifacts that appear when there are discontinuity count occurrences. Please help!
mandr
 
Posts: 6
Joined: Tue Apr 29, 2014 2:30 am

Re: DS213J + HDHomerun HDHR3-US artifacts (discontinuity)

Postby Oberon » Mon May 05, 2014 9:21 am

It seems that HDHomeRun library uses UDP as a transport protocol and packets get lost when HDD is active. We will confirm this with SiliconDust to see if anything can be done.
Oberon
 
Posts: 11763
Joined: Thu Sep 06, 2007 5:04 am

Re: DS213J + HDHomerun HDHR3-US artifacts (discontinuity)

Postby mandr » Fri May 09, 2014 2:16 am

Hi Oberon,

Thank you for looking into this, but I actually solved the problem: I had enabled Jumbo Frames (to 9K) when doing some tests on the Synology NAS and left it on for months after I forgot about it. The speed on it degraded but I never noticed because it was still reasonably fast since I only stream media from it.

I tried in vain the following:

1. Adding a switch and connecting the NAS and HDHomerun to it, then connecting that to the router (Linksys E3000 running DD-WRT). Nothing changed.
2. Changing antennas. I increase the signal strength (to 100%) and signal quality (to 70% - 80%). Nothing changed.

Finally, when I tried to do a file copy from my from my NAS to my Windows 7 computer, I noticed I only got 15-20 MB/s (120 Mbps - 160 Mbps). This was low since all my network "nodes" are Gigabit. That's when I realized that:

a. DS213j had Jumbo Frames MTU enabled to 9K
b. Linksys E3000 running the DD-WRT "v24-sp2 (04/13/11) big - build 16785" may or may not even support Jumbo Frames. Unsure, but it doesn't matter now.
c. All other computers had an MTU of ~1.5K

By getting a good stream with no artifacts in case (4) and (5) above from a direct connection to the HDHomerun , I was bypassing the NAS for the stream. So that gave me the clue that the NAS was the problem. Long story short, stay away from Jumbo Frames as they can cause more problems than answers. After disabling it, my copy speeds went from 15-20 Mb/s to 50 - 60 MB/s on the Windows 7 PC. Mind you, it's an older Asrock ION 300 (almost 5 years old) with Atom Processor (1.6 GHz), so channel switching in XBMC is a bit slow from DVBLink, but my gut feeling is that it's the slow CPU on my machine.

Hopefully this helps someone out there.

Final Note: Your software is amazing!! I will be purchasing it once version 5 hits final. Also, it's still interesting to see what SiliconDust says about UDP packets getting dropped when the HDD is active. Definitely something that could degrade quality. Obviously, you always want the least amount dropped since UDP packets can never get retransmitted in the context of streaming video/audio.

Thanks,
Mandr
mandr
 
Posts: 6
Joined: Tue Apr 29, 2014 2:30 am


Return to DVBLink TV Server for Synology NAS

Who is online

Users browsing this forum: No registered users and 4 guests