Zombie Streams not terminating SOLVED

DVBLink Kodi PVR addon is discussed here

Zombie Streams not terminating SOLVED

Postby ampeer » Sun Jun 04, 2017 9:39 am

I am using Kodi on Nvidia Shield TV with Octopus Net DVB-S tuner and DVBLink Server on Synology NAS for quite some time now (>1year) without major problems. But since some weeks (maybe two or three) I am experiencing repeating stream crashes. The resulting zombi streams persist in the Octopus Net tuner as well as in the dvb link server and prevent any TV playback in Kodi unless both systems are rebooted / restarted which will finally kill the zombi stream!

While this happened quite rarely in the last weeks, it occurs way too often in the last days. TV is becoming unusuable. Yesterday I was forced to reboot all systems about three times on one single evening!

What is happening here!? Does anyone have a clue about this? Is anyone experiencing similar issues? Any feedback is highly appreciated.
Last edited by ampeer on Wed Jun 07, 2017 9:35 pm, edited 1 time in total.
Tuner: DigitalDevices Octopus NET V2 S2 Max SAT>IP 8x
Server: TVSource&TVAdvisorDE Ver.6 on Synology DS716+II DSM6
Client: Kodi17 on NvidiaShield
ampeer
 
Posts: 74
Joined: Mon Jul 21, 2014 10:00 pm


Re: Zombi Streams not terminating

Postby Montoya » Sun Jun 04, 2017 9:48 am

You don't have to reboot for killing the active streams. Just go to the sources tab in your DVBLink Server settings page and click the edit source button, of the occupied source with the zombie streams. This will close all active streams from that source.

I noticed this too and it looks like KODI is the problem, for not closing the stream in DVBLink server :!:
This does NOT happen with DVBLink player/viewer, so DVBLogic should look at the DVBLink PVR addon for Kodi, to fix this problem :idea:
DVBLink server 6.0.0 build14499, DVBLink TVSource 6.0.0 build14061, DVBLink for IPTV build 13107
Kodi 18.0-ALPHA1 Git:20180125-7379a75, Win10 Pro x64 1709 build16299.125
Montoya
 
Posts: 134
Joined: Fri Apr 29, 2016 6:06 pm

Re: Zombi Streams not terminating

Postby ampeer » Sun Jun 04, 2017 2:15 pm

Thanks for your feedback Montoya. Glad to hear that I am not the only one struggling with this issue.

I just stopped playback of a stream and again it persisted as zombie stream.

Anyway, the button you mentioned on the sources tab is not the "edit" button but the "configure" button.

Unfortunately this will not terminate the zombie on the Octopus Net tuner which still requires a reboot to terminate that zombie. Playback is not possible unless you do so.

Thanks anyway Montoya, because the source edit trick reduces the time needed to be able to start the playback again.

Still a feedback from @Oberon would be helpful to see if that issue is known at DVBLogic and if it is actually worked on.
Tuner: DigitalDevices Octopus NET V2 S2 Max SAT>IP 8x
Server: TVSource&TVAdvisorDE Ver.6 on Synology DS716+II DSM6
Client: Kodi17 on NvidiaShield
ampeer
 
Posts: 74
Joined: Mon Jul 21, 2014 10:00 pm

Re: Zombi Streams not terminating

Postby Montoya » Sun Jun 04, 2017 3:04 pm

My error indeed, but good to see that you found your way with what I tried to explain, to click the "wrench" button instead of the edit button :)
DVBLink server 6.0.0 build14499, DVBLink TVSource 6.0.0 build14061, DVBLink for IPTV build 13107
Kodi 18.0-ALPHA1 Git:20180125-7379a75, Win10 Pro x64 1709 build16299.125
Montoya
 
Posts: 134
Joined: Fri Apr 29, 2016 6:06 pm

Re: Zombi Streams not terminating

Postby ampeer » Tue Jun 06, 2017 12:59 pm

I finally found that a simple reboot did no really fix the Octopus Net Tuner. I had to do a factory reset including unplugging of the device to finally kill a zombie stream that still persisted after a reboot from the web interface.

Since then the situation improved. But I am still not sure if it is really solved. Will update my findings soon.
Tuner: DigitalDevices Octopus NET V2 S2 Max SAT>IP 8x
Server: TVSource&TVAdvisorDE Ver.6 on Synology DS716+II DSM6
Client: Kodi17 on NvidiaShield
ampeer
 
Posts: 74
Joined: Mon Jul 21, 2014 10:00 pm

Re: Zombi Streams not terminating

Postby ampeer » Wed Jun 07, 2017 9:08 pm

The problem persists. Approx. once a day the system breaks. I have around 10 recordings scheduled per day. Whenever I look at the recordings I can see that the last recordings do have file size of zero meaning that the TV stream could not be received. Fixing as described by rebooting / killing zombie streams will help for some hours before the system breaks again.

What can I do? Is anyone interested in log files? Should I try a clean reinstallation of DVB Link server? Is there a directory on the Synology NAS that can be wiped for reseting the server in some way?

Any help is highly appreciated.
Tuner: DigitalDevices Octopus NET V2 S2 Max SAT>IP 8x
Server: TVSource&TVAdvisorDE Ver.6 on Synology DS716+II DSM6
Client: Kodi17 on NvidiaShield
ampeer
 
Posts: 74
Joined: Mon Jul 21, 2014 10:00 pm

Re: Zombie Streams not terminating SOLVED

Postby ampeer » Wed Jun 07, 2017 9:36 pm

OK, this is the problem:
viewtopic.php?f=69&t=32069
Tuner: DigitalDevices Octopus NET V2 S2 Max SAT>IP 8x
Server: TVSource&TVAdvisorDE Ver.6 on Synology DS716+II DSM6
Client: Kodi17 on NvidiaShield
ampeer
 
Posts: 74
Joined: Mon Jul 21, 2014 10:00 pm


Return to DVBLink Kodi PVR Addon

Who is online

Users browsing this forum: No registered users and 7 guests