Unable to play some channels

DVBLink Kodi PVR addon is discussed here

Unable to play some channels

Postby amelsfort » Thu Feb 09, 2017 10:57 pm

For a little while now, the Kodi PVR add-on is unable to play some channels. Most of the channels work fine, but, for example, VH1 Classic (on Ziggo in Tilburg) won't play. I get the waiting icon which just stops after a while.
The Kodi-log shows me:
Code: Select all
22:50:16.575 T:6872  NOTICE: VideoPlayer: Opening: pvr://channels/tv/All channels/pvr.dvblink_229.pvr
22:50:16.575 T:6872 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
22:50:16.576 T:6872   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 104 for 1.
22:50:16.576 T:6872   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 105 for 1.
22:50:16.577 T:5288  NOTICE: Creating InputStream
22:50:37.885 T:5288   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
22:50:37.885 T:5288   ERROR: CCurlFile::Open failed with code 0 for http://<server>:8101/dvblink/timeshift?client=1
22:50:37.885 T:5288   ERROR: XFILE::CFileCache::Open - failed to open source <http://<server>:8101/dvblink/timeshift?client=1>
22:50:37.956 T:5288  NOTICE: Creating Demuxer
22:50:37.957 T:5288   ERROR: CDVDDemuxFFmpeg::Open - error probing input format, pvr://channels/tv/All channels/pvr.dvblink_229.pvr
22:50:37.971 T:5288   ERROR: Previous line repeats 9 times.
22:50:37.971 T:5288   ERROR: CVideoPlayer::OpenDemuxStream - Error creating demuxer
22:50:37.971 T:5288  NOTICE: CVideoPlayer::OnExit()
22:50:38.699 T:6872  NOTICE: CVideoPlayer::CloseFile()
22:50:38.699 T:6872  NOTICE: VideoPlayer: waiting for threads to exit
22:50:38.699 T:6872  NOTICE: VideoPlayer: finished waiting
22:50:38.699 T:6872  NOTICE: CVideoPlayer::CloseFile()
22:50:38.699 T:6872  NOTICE: VideoPlayer: waiting for threads to exit
22:50:38.699 T:6872  NOTICE: VideoPlayer: finished waiting


This is a scrambled channel, but other scrambled channels work fine. The logs of DVBLink don't show anything at all.
I also noticed the Acamd monitor doesn't show anything, which makes me believe the server isn't switching channels or trying to decode the channel.

Today I also did a rescan of the channels and it found some changes, but I'm still unable to watch VH1 Classic.

When I switch to a channel which is working, I see the following lines in the logs:
Code: Select all
22:57:43.126 T:6872  NOTICE: VideoPlayer: Opening: pvr://channels/tv/All channels/pvr.dvblink_235.pvr
22:57:43.126 T:6872 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
22:57:43.126 T:6872   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 104 for 1.
22:57:43.126 T:6872   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 105 for 1.
22:57:43.128 T:2428  NOTICE: Creating InputStream
22:57:47.177 T:2428  NOTICE: Creating Demuxer
22:57:47.298 T:2428  NOTICE: Opening stream: 0 source: 256
22:57:47.298 T:2428  NOTICE: Creating video codec with codec id: 28
22:57:47.298 T:2428  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
22:57:47.298 T:2428  NOTICE: Creating video thread
22:57:47.298 T:2428  NOTICE: Opening stream: 2 source: 256
22:57:47.298 T:2428  NOTICE: Finding audio codec for: 86019
22:57:47.299 T:6912  NOTICE: running thread: video_thread
22:57:47.299 T:2428  NOTICE: Creating audio thread
22:57:47.299 T:2428  NOTICE: Opening stream: 4 source: 256
22:57:47.299 T:2428  NOTICE: Opening stream: 3 source: 256
22:57:47.299 T:2428  NOTICE: waiting for teletext data thread to exit
22:57:47.299 T:8800  NOTICE: running thread: CVideoPlayerAudio::Process()
22:57:47.300 T:2428  NOTICE: Creating teletext data thread
22:57:47.301 T:8284  NOTICE: running thread: CDVDTeletextData
22:57:48.518 T:2428  NOTICE: Opening stream: 0 source: 256
22:57:48.518 T:2428  NOTICE: Creating video codec with codec id: 28
22:57:48.518 T:2428  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
22:57:48.518 T:2428  NOTICE: Opening stream: 2 source: 256
22:57:48.518 T:2428  NOTICE: Closing stream player 3
22:57:48.519 T:2428  NOTICE: Opening stream: 4 source: 256
22:57:48.519 T:2428  NOTICE: Opening stream: 3 source: 256
22:57:48.520 T:6912  NOTICE: CDVDVideoCodecFFmpeg::GetFormat - Creating DXVA(1920x1080)
22:57:48.575 T:6872  NOTICE: D3D: rendering method forced to DXVA processor
22:57:48.576 T:6872  NOTICE: DXVA::CProcessorHD::InitProcessor: Supported deinterlace methods: Blend:no, Bob:yes, Adaptive:yes, MoComp:yes.
22:57:48.576 T:8800  NOTICE: Creating audio stream (codec id: 86019, channels: 6, sample rate: 48000, no pass-through)
22:57:48.620 T:6872 WARNING: CWinRenderer::UpdateVideoFilter - chosen scaling method 1 is not supported by renderer
22:57:48.634 T:8440  NOTICE: CAEEncoderFFmpeg::Initialize - AC3 encoder ready
22:57:49.486 T:6912 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:57:50.637 T:6912 WARNING: Previous line repeats 1 times.
22:57:50.637 T:6912  NOTICE: CDVDVideoCodecFFmpeg::CDropControl: calculated diff time: 40000
amelsfort
 
Posts: 15
Joined: Mon Jan 25, 2010 10:15 pm


Re: Unable to play some channels

Postby amelsfort » Mon Feb 13, 2017 4:33 pm

Never mind. It seems that Acamd was using a cache with old data in it. I removed some files and all channels work fine now!
amelsfort
 
Posts: 15
Joined: Mon Jan 25, 2010 10:15 pm


Return to DVBLink Kodi PVR Addon

Who is online

Users browsing this forum: No registered users and 1 guest

cron