BUG Libreelec 7.95.1. Stuttering on HD Channels

DVBLink Kodi PVR addon is discussed here

BUG Libreelec 7.95.1. Stuttering on HD Channels

Postby shanemarsh28 » Wed Jan 18, 2017 7:44 pm

Hi Guys,

I have been battling with a bug that I fell could/might be more at hand with you guys. Libreelec is on version 7.95.1 using Kodi 17 RC3 and since this update, HD channels have been stuttering under certain conditions that I have not been able to fully pin down.

I have attached the log files for both a clean Kodi Install and the DVB Server.

Within the KODI log files I see the following repeated errors at the time it's stuttering. This caught my attention:

Code: Select all
18:14:28.946 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] SPS unavailable in decode_picture_timing
18:14:28.946 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] non-existing PPS 0 referenced
18:14:28.946 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] SPS unavailable in decode_picture_timing
18:14:28.946 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] non-existing PPS 0 referenced
18:14:28.947 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] SPS unavailable in decode_picture_timing
18:14:28.947 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] non-existing PPS 0 referenced
18:14:28.947 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] SPS unavailable in decode_picture_timing
18:14:28.947 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] non-existing PPS 0 referenced
18:14:28.947 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] SPS unavailable in decode_picture_timing
18:14:28.947 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] non-existing PPS 0 referenced
18:14:28.948 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] SPS unavailable in decode_picture_timing
18:14:28.948 T:1874850720   ERROR: ffmpeg[6FBFF3A0]: [NULL] non-existing PPS 0 referenced


I didn't see anything untoward with the server side logs but being honest I'm not 100% sure what I am looking for. I have run a lot of tests already and I have a thread running on Libreelec's forums as their guys are looking into it also. (https://forum.libreelec.tv/thread-3961.html)

Any input from you would be appreciated as I would love to get this issues resolved as quickly as possible.

Shane
Attachments
log-2017-01-18-18.28.59.zip
(154.87 KiB) Downloaded 73 times
dvblink-log-20170118-1829.zip
(64.87 KiB) Downloaded 74 times
shanemarsh28
 
Posts: 29
Joined: Sun May 19, 2013 9:55 pm


Re: BUG Libreelec 7.95.1. Stuttering on HD Channels

Postby goodton » Sat Feb 18, 2017 11:23 am

I`m also experiencing channel stuttering but only when live-tv -channel is started or changed. This happens in all channels and can last several seconds until the channel is finally "synced". After this the channel plays correctly. I had a forum discussion about this issue in Kodi-forum and it seems that there might be issue between the current Kodi-addon and the new live stream playing mechanism in Kodi 17. Here is the discussion:

http://forum.kodi.tv/showthread.php?tid=306231

So it starts to look like the current dvblink pvr-addon in Kodi 17 has some problems filling the demux buffer for new Kodi-videoplayer, which cause juddering because the buffer dries out. Until it finally fills up and playing continues normally, at least in my case. Might be related also to a problem that dvblink does not seem to correctly identify pvr-stream as a realtime-stream to Kodi, which also causes those strange passthrough-audio issues.

I can also see lot of these ffmpeg-errors related to SPS/PPS in my Kodi-debug logs.
goodton
 
Posts: 5
Joined: Sat Feb 18, 2017 10:30 am


Return to DVBLink Kodi PVR Addon

Who is online

Users browsing this forum: No registered users and 3 guests

cron