DVBLink Addon for Raspberry 3 not working on LibreElec 7.0.2

DVBLink Kodi PVR addon is discussed here

DVBLink Addon for Raspberry 3 not working on LibreElec 7.0.2

Postby gromit42 » Mon Aug 22, 2016 5:09 pm

Hello,
my problem since almost one month of trying:
On my RaspBerry 3, with Bootberry and also without, on a newly installed SD-Card, DVBlink addon doesn't work from the beginning.
Downloaded/installed the addon (version was 2.1.7), activated TV, then after a few seconds while activating suddenly reboot of LibreElec 7.0.2, same as in 7.0.1.
After reboot, TV is disabled again, and so on...
Is there a general problem with DVBlink and LibreElec 7.x / Jarvis ??
Or are there any logfiles I can check for the reason myself?
On Openelec (stable but old version 6.0.3) the addon works just fine :-(
Thanks in advance!
gromit42
 
Posts: 18
Joined: Wed Jun 08, 2016 1:15 pm


Re: DVBLink Addon for Raspberry 3 not working on LibreElec 7

Postby xbeel » Sun Aug 28, 2016 1:16 pm

same behavior on OpenELEC 7.0 beta 3 (Jarvis 16.1)
xbeel
 
Posts: 1
Joined: Sun Aug 28, 2016 1:12 pm

Re: DVBLink Addon for Raspberry 3 not working on LibreElec 7

Postby gromit42 » Sun Aug 28, 2016 9:55 pm

In another thread, https://forum.libreelec.tv/thread-1400.html, I read about another version DVBLink 3.3.3, Just can't tell if this concerns the DVBLink plugin, e.g. a nightly build, beta version, or a different software.
I would appreciate any response from the developers concerning these problems, since there's no TV since almost two weeks at home. Only undesired way would be the return to the apparently quite dead OpenElec branch.
Thanks in advance!
gromit42
 
Posts: 18
Joined: Wed Jun 08, 2016 1:15 pm

Re: DVBLink Addon for Raspberry 3 not working on LibreElec 7

Postby Laurens » Sat Sep 03, 2016 4:48 pm

Hi

I have the same problem.

Enabling the DVBLogic plugin in LibreElec brings Kodi in an endless reboot loop. I enabled version 3.3.4.
It used to work fine a couple of weeks ago in OpenElec, but it's doing this now for about 2 weeks. It did this in OpenELEC 7.0 Beta 3 and I just did a full clean reinstall with v7.90.005 Alpha where it does just the same as it did in OpenELEC.

Attached some debug logs. For example I do see messages like this:

Sep 03 16:54:29 Kodi kernel: PVRManager[881]: segfault at 20 ip 00007f2ea808cfca sp 00007f2e5efaf920 error 4 in pvr.dvblink.so.3.3.4[7f2ea804c000+68000]

Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f2ea808cfca in DVBLinkClient::GetSchedules(ADDON_HANDLE_STRUCT*, dvblinkremote::RecordingList const&) () from /storage/.kodi/addons/pvr.dvblink/pvr.dvblink.so.3.3.4
[Current thread is 1 (Thread 0x7f2e5efb2700 (LWP 881))]

I'm not running it on a Raspberry Pi, just on generic hardware.

Greetings
Laurens
Attachments
Archief.zip
(169.39 KiB) Downloaded 160 times
Laurens
 
Posts: 46
Joined: Thu Jul 10, 2014 8:53 am

Re: DVBLink Addon for Raspberry 3 not working on LibreElec 7

Postby gromit42 » Fri Sep 09, 2016 10:24 am

Hello again,
does anyone, for example Oberon, have any clue?
Is LibreElec still not supported officially, or what may be the reason?
I would love to help if I had any clue where to search or what else to check....
Surely watching TV is overrated, but after about seven weeks without ....
gromit42
 
Posts: 18
Joined: Wed Jun 08, 2016 1:15 pm

Re: DVBLink Addon for Raspberry 3 not working on LibreElec 7

Postby Laurens » Fri Sep 09, 2016 10:31 am

Hi

Found the issue, but didn't tested it fully yet.
But it stopped crashing at reboot.
Problem was the "-signs (double quotes) in recording searches. I wanted to make sure only programs are recorded with the full name ("De 16").
Still don't know how to do that?
Laurens
 
Posts: 46
Joined: Thu Jul 10, 2014 8:53 am

Re: DVBLink Addon for Raspberry 3 not working on LibreElec 7

Postby gromit42 » Mon Sep 12, 2016 1:51 pm

@Laurens:
Thank you so much, you are great :)
Removed ALL the recording tasks, TV could be activated at once.
Added a few specific record tasks for single TV shows, no problem.
Added a search task for a specific search pattern, e.g. "Blues brothers 2000", after a short time Raspberry Pi reboot.
Removed only this task, TV fine again.
Tested on my Raspberry 3, LibreElec 7.0.2.
But the source of the problem should be removed, or else no more way to do a search pattern for future recordings...
Thanks again !
gromit42
 
Posts: 18
Joined: Wed Jun 08, 2016 1:15 pm


Return to DVBLink Kodi PVR Addon

Who is online

Users browsing this forum: No registered users and 2 guests