Xbian?

DVBLink Kodi PVR addon is discussed here

Xbian?

Postby ashley » Mon Feb 23, 2015 11:46 am

Hi, was running openelec on my rpi2 and this sucessfully ran up dvblink plugin and I had live TV working fine.
However openelec didn't provide the control I needed at the alsa level so I've switched to xbian.
Under xbian, I can install the plugin and configure it etc and the guide and EPG come through fine,.
As soon as I select a channel to watch, I see the working moving icon for about 5 seconds and then nothing.
any ideas?
Has anyone been able to get the pvrclient working under the latest version of xbian?
If it helps xbian uses Kodi v 14.2 beta 2 currently.
Thisa is the error which appears in the kodi logs when the channel is selected - then about 2-3 seconds later, nothing happens.

00:23:37 T:1961132032 NOTICE: DVDPlayer: Opening: pvr://channels/tv/All channels/59.pvr
00:23:37 T:1961132032 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
00:23:37 T:1669329936 NOTICE: Thread DVDPlayer start, auto delete: false
00:23:37 T:1669329936 NOTICE: Creating InputStream
00:23:39 T:1669329936 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 404
00:23:39 T:1669329936 NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1
00:23:39 T:1669329936 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 404
00:23:39 T:1669329936 ERROR: CCurlFile::CReadState::Connect, didn't get any data from stream.
00:23:39 T:1669329936 ERROR: Open - failed to open source <http://192.168.3.3:8101/dvblink/http_stream_1>
00:23:39 T:1669329936 NOTICE: Creating Demuxer
00:23:39 T:1669329936 ERROR: Open - error probing input format, pvr://channels/tv/All channels/59.pvr
00:23:39 T:1669329936 ERROR: Previous line repeats 9 times.
00:23:39 T:1669329936 ERROR: OpenDemuxStream - Error creating demuxer
00:23:39 T:1669329936 NOTICE: CDVDPlayer::OnExit()

ah. just found this link saying that all streams seems to be broken on Kodi 14.2 on xbian;
https://github.com/xbianonpi/xbian/issues/685
When I read "bleeding edge" rpi release I naively still assumed the thing would work! oh well lesson learned!

Everything now working again after downgrading to; XBian_2015.02.07_rpi2.img
Intel i5 quad, GTX1060
1xTBS6205
DVBlink 6 on Win10 x64 with Nexus 5x/9/SPMC/Kodi clients
Dumped MCE for Nvidia Shield TV running SPMC v17 with dvblink plugin!
Dumped Sky TV for being a waste of money
ashley
 
Posts: 315
Joined: Sun Jul 10, 2011 9:01 am
Location: Auckland, New Zealand


Return to DVBLink Kodi PVR Addon

Who is online

Users browsing this forum: No registered users and 3 guests

cron