problem switching channels in KODI 14.1 on Raspberry Pi 2

DVBLink Kodi PVR addon is discussed here

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby michasvision » Tue Mar 24, 2015 9:22 pm

I've updated:
DVBLink Server 5.1.0 Build: 11207
DVBLink Connect! Server 5.1.0 Build: 11207
DVBLink TVSource 5.1.0 Build: 11225
and restarted the server.

I've disabled timeshift and transcoding in KODI PVR-Addon.
The result is almost the same: black screens on some channels on "TV-Box".
The only difference is that a black channel sometimes recovers now and you might get a picture...
On the other hand the channels now sometimes freeze.

I've dowloaded the DVBLink-app from google play store.
Without transcoding I was able to watch channels with Google Video Player for a few seconds ... until they froze... started... froze.
With transcoding the "TV-Box" achieved to bring down the server, i had to restart both!!
(the dvblink_server was still running but a connection was neither possible with browsers nor with the NUC-client).

To be honest:
The results are disappointing.
I think that this environment is far from being a "home-entertainment" :-(

On which Android-client are you testing?
(I'm thinking about using a custom finless rom: http://www.freaktab.com/showthread.php? ... ss-1-8-ROM)

Any recommendations?
michasvision
 
Posts: 18
Joined: Fri Mar 20, 2015 12:20 pm


Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby fab4272 » Wed Mar 25, 2015 5:01 am

I have exactly the same problem with my Minix X8 running Kodi 14.1 and grabbing TV via the latest DVBlink client/server packages. The Minix X8 is running an Amlogic S802 chipset.

Playing video via files or streaming is ok, but as soon as I go to watch live TV, the first time it works, then second time maybe, but buffers for 5-10 seconds, then 3rd and every time after that a black screen, audio only. Will only work if I turn off amlogic H/W accel in Kodi.

I have a feeling it's something to do with DVBlink client/server and not Kodi as I can play any video, any type and Kodi will play it. With Live TV, I have to turn off amlogic H/W accel to get it to work, but the picture then is less than perfect.
fab4272
 
Posts: 40
Joined: Thu Jul 10, 2014 3:29 am

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby clarkss47 » Wed Mar 25, 2015 5:33 am

I am almost certain it is a problem with Kodi running on Android. I also have a Tronsmart S89H that has the same problem with Kodi 14.1 sometimes. I have installed OpenELEC on it, and it worked flawlessly. I have two TV servers running, DVBLink running on my Synology and tvheadend server running on a MK808B+ (S805). Both backends exhibit the same symptoms while running on on my S89H as a client. I have had other Kodi versions that did not have those problems, but don't remember what version.
Tuner: HDHomeRun HDTC-2US
Tuner: HDHomeRun HDHR3-US
Server: Synology DS211j running DSM 5.1 DVBLink TVSource 5.1.0, EPG PercData 5.1
Server: MK808B+ running tvheadend server, EPG Schedules Direct
Clients:Tronsmart R68 Meta, Nexus Player, Minix X8-H Plus
clarkss47
 
Posts: 153
Joined: Sun Feb 09, 2014 5:33 pm
Location: United States, Michigan

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby the_man » Wed Mar 25, 2015 11:12 am

michasvision wrote:...
I've disabled timeshift and transcoding in KODI PVR-Addon.
The result is almost the same: black screens on some channels on "TV-Box".
The only difference is that a black channel sometimes recovers now and you might get a picture...
On the other hand the channels now sometimes freeze.

I've dowloaded the DVBLink-app from google play store.
Without transcoding I was able to watch channels with Google Video Player for a few seconds ... until they froze... started... froze.
With transcoding the "TV-Box" achieved to bring down the server, i had to restart both!!
(the dvblink_server was still running but a connection was neither possible with browsers nor with the NUC-client).
...
Any recommendations?


Ok, with regard kodi, looks like some kind of issue with kodi for android(especially with Live TV streaming ), also please try watch live TV via DLNA in Kodi (go to Videos- Files - Add video -browse -UPnP Devices - DVBLink server- OK -OK)
I made some researches:
- start channel (black screen, oudio is present )
- clicked on pause (waited 5-10 sec.)
- clicked on play (the same black screen, oudio is present )
- clicked on Fast forward button, then Play again (and Picture appear)

For DVBLink-app i recommend use MX Player with Software decoder is Turned on. "froze... started... froze" behaviour happens with HD channels because of insufficient power of device.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby michasvision » Wed Mar 25, 2015 4:19 pm

Thank you very much for the support so far and the workarounds you provided...

I'm glad that you could reproduce this issue.
However I'm not sure how the flow of information between Team-KODI and the PVR-Addon developers usually happens.
Is there something I can do at the moment to speed things up?

Please let me know if I can test / log or be of any other help...
michasvision
 
Posts: 18
Joined: Fri Mar 20, 2015 12:20 pm

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby clarkss47 » Wed Mar 25, 2015 10:50 pm

michasvision wrote:Thank you very much for the support so far and the workarounds you provided...

I'm glad that you could reproduce this issue.
However I'm not sure how the flow of information between Team-KODI and the PVR-Addon developers usually happens.
Is there something I can do at the moment to speed things up?

Please let me know if I can test / log or be of any other help...


Try rolling back to Kodi 14.0, December 23, and see if that helps.
Tuner: HDHomeRun HDTC-2US
Tuner: HDHomeRun HDHR3-US
Server: Synology DS211j running DSM 5.1 DVBLink TVSource 5.1.0, EPG PercData 5.1
Server: MK808B+ running tvheadend server, EPG Schedules Direct
Clients:Tronsmart R68 Meta, Nexus Player, Minix X8-H Plus
clarkss47
 
Posts: 153
Joined: Sun Feb 09, 2014 5:33 pm
Location: United States, Michigan

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby clarkss47 » Wed Mar 25, 2015 11:05 pm

Best for live streaming, XBMC 13.2, August 17.
Tuner: HDHomeRun HDTC-2US
Tuner: HDHomeRun HDHR3-US
Server: Synology DS211j running DSM 5.1 DVBLink TVSource 5.1.0, EPG PercData 5.1
Server: MK808B+ running tvheadend server, EPG Schedules Direct
Clients:Tronsmart R68 Meta, Nexus Player, Minix X8-H Plus
clarkss47
 
Posts: 153
Joined: Sun Feb 09, 2014 5:33 pm
Location: United States, Michigan

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby michasvision » Sat Mar 28, 2015 1:58 pm

@clark: Thanks, which version of XBMC DVBLink-addon are you using?

I have installed XBMC 13.2 which has a pre-installed Version 1.9. of DVBLink-addon.
If I then try to enable this version of DVBLink-addon (1.9.0 ?) a warning is issued (not compatible with current version of DVBLogic-Server?) ...
If I try to use the current version of DVBLink-addon (1.9.13) a warning is issued (not compatible with XBMC 13.2) ...
.. seems like a catch22.

@the_man: Any news? How can I help?
michasvision
 
Posts: 18
Joined: Fri Mar 20, 2015 12:20 pm

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby clarkss47 » Sat Mar 28, 2015 4:52 pm

michasvision wrote:@clark: Thanks, which version of XBMC DVBLink-addon are you using?

I have installed XBMC 13.2 which has a pre-installed Version 1.9. of DVBLink-addon.
If I then try to enable this version of DVBLink-addon (1.9.0 ?) a warning is issued (not compatible with current version of DVBLogic-Server?) ...
If I try to use the current version of DVBLink-addon (1.9.13) a warning is issued (not compatible with XBMC 13.2) ...
.. seems like a catch22.

@the_man: Any news? How can I help?


With XBMC 13.2 August 17, the DVBLink addon version 1.9.1, and it has the "Enable timeshift" setting available on the "Stream" tab. I am running DSM 5.1 DVBLink TVSource 5.1.0 on my Synology NAS. I did not have any problems running this version of XBMC, also my rom is rooted, if that makes a difference.
Tuner: HDHomeRun HDTC-2US
Tuner: HDHomeRun HDHR3-US
Server: Synology DS211j running DSM 5.1 DVBLink TVSource 5.1.0, EPG PercData 5.1
Server: MK808B+ running tvheadend server, EPG Schedules Direct
Clients:Tronsmart R68 Meta, Nexus Player, Minix X8-H Plus
clarkss47
 
Posts: 153
Joined: Sun Feb 09, 2014 5:33 pm
Location: United States, Michigan

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby RTK » Sat Mar 28, 2015 10:46 pm

I briefly ran Kodi 14 on S802 Amlogic box with Android 4.4 and also experienced the black screen issue with live TV and no problems with playback of any local files. After reflashing to OpenELEC, there have been no black screen issues running Kodi PVR client with DVBlink as backend so there must be something about running Kodi on Android. Perhaps a new build of Kodi will resolve the issue although someone is likely going to have to provide a log to Kodi dev team to get issue resolved.
RTK
 
Posts: 73
Joined: Wed Feb 11, 2015 5:15 pm

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby michasvision » Sun May 17, 2015 10:52 pm

Is this issue solved with PVR Addon 1.9.13.1 for Kodi 14.x Helix ?
michasvision
 
Posts: 18
Joined: Fri Mar 20, 2015 12:20 pm

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby Toddel » Mon May 18, 2015 9:24 pm

I see same issue like initial description.
Synology DS 1515+ running DVBLink TVSource 5.1.0 11420 with DVBLink Server 5.1.0 11218 with DVB-C content serving Raspberry Pi 2 AND Raspberry Pi with OpenELEC 5.0.8.
When video hardware acceleration is on, the HD runs fine and SD stays black
When video hardware acceleration is off, the HD runs stuttering and SD fine
Took me a while to figure that out.
Same backend with Kodi on Windows runs fine.
So looks like an issue with Open Elec or Raspberry Pi
Toddel
 
Posts: 11
Joined: Mon May 18, 2015 9:14 pm

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby judge190 » Wed May 20, 2015 9:52 am

Strongly suggest getting the mpeg-2 license. Had the same issue as the orginal post on this thread. Installed the mpeg-2 license and now working perfectly! No issues switching between HD>SD SD>HD.... no blank screens at all.

My setup:
DVBLink 5.1, RPI2 KODI - OSMC, DVBLink PVR addon 1.9.13.x + MPEG-2 license

Thanks,
judge190
 
Posts: 11
Joined: Sat Oct 12, 2013 10:33 am

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby Videonisse » Wed May 20, 2015 10:34 am

Maybe Kodi should warn when HW codec is enabled that MPEG license are required for SD video?
Win 7 64-bit SP1, Intel i5-3570K 3,4GHz HD 4000 Graphics, 6GB, TBS 6984 S2 Quad,TBS 6280 T2 Dual
DVBLink 5.5.0 Connect & TVSource (mc_recorder), CD S Thor 0.8W,FTA Aastra 19.2E, S FTA T2, ACAMD 0.6.2
Clients iPhone 4S 5S 6S, iPad2 iOS 9,Win 7 PCs
Videonisse
 
Posts: 573
Joined: Mon Nov 21, 2011 10:29 pm
Location: Stocholm, sweden

Re: problem switching channels in KODI 14.1 on Raspberry Pi

Postby Toddel » Wed May 20, 2015 1:23 pm

at least for me I issue is not linked to the codec license - since it's installed. All other recorded films are playing so far without issues
Toddel
 
Posts: 11
Joined: Mon May 18, 2015 9:14 pm

PreviousNext

Return to DVBLink Kodi PVR Addon

Who is online

Users browsing this forum: No registered users and 3 guests