get_recordings episodes missing in xml

DVBLink Remote API clients and tools

get_recordings episodes missing in xml

Postby Hagen » Thu May 26, 2016 6:53 pm

Hy,

i tried to work with the Remote API and evrthings works pretty good.

By checking the XML File for all series will be recorded next i found a mistake.
There should be 3 episodes one after another but the XML only cotains two.
I changed the value for recording only new episodes to false. In effekt the XML contains 2 episodes in the evening and 3 episodes repated late at night.
Tried to send the post command below with Crome Advanced rest Client and Putty API.
Both with the same result.
Post Command:
command=get_recordings&xml_param=<?xml version="1.0" encoding="utf-8" ?> <recordings xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.dvblogic.com"/>
What can i do to get the correct response?
Inside web interface and app everthing is ok.

I just installed DVBLink 6 on my second NAS and it worked perfekt.

Thanks Hagen
Digital Devices Octopus Net DVB-C
Synology DS214Play+ DSM6 + DVBLink 5 + TV Adviser
Raspberry Pi2 B+ Openelec
Hagen
 
Posts: 10
Joined: Sat Jan 24, 2015 1:36 pm


Re: get_recordings episodes missing in xml

Postby Oberon » Fri May 27, 2016 8:51 am

For my understanding -
- you have a schedule, which results in 3 recording timers in dvblink web interface
- however, when you use get_recordings function you get an xml with two recording timers
correct?
Oberon
 
Posts: 11763
Joined: Thu Sep 06, 2007 5:04 am

Re: get_recordings episodes missing in xml

Postby Hagen » Fri May 27, 2016 8:57 am

Yes this is correct.

Only if the Episode is repeated at night the timers are correct.

Can you help me?

Thanks Hagen
Digital Devices Octopus Net DVB-C
Synology DS214Play+ DSM6 + DVBLink 5 + TV Adviser
Raspberry Pi2 B+ Openelec
Hagen
 
Posts: 10
Joined: Sat Jan 24, 2015 1:36 pm


Return to Development corner

Who is online

Users browsing this forum: No registered users and 2 guests

cron