Dvblink for XBMC

DVBLink Remote API clients and tools

Re: Dvblink for XBMC

Postby DSD » Sat Oct 20, 2012 9:09 am

Selcal wrote:DSD, please don't leave me now :).

I've not forgotten you. :)

Here are a few things you can try:
- Restart the computer before trying the add-on, this so that DVBLink is restarted.
- Also in the server address setting for the add-on put the ip-address instead of the DNS.

You could also set the log-level on the DVBLink server to extended so that almost everything is logged and then post it here.
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am


Re: Dvblink for XBMC

Postby Selcal » Sat Oct 20, 2012 9:39 am

Thanks :)

I've tried the restart, and the direct IP (remote and over VPN with a local address).

I'll try to get the logs over the weekend, more to come!
Selcal
 
Posts: 35
Joined: Thu Dec 11, 2008 4:42 pm

Re: Dvblink for XBMC

Postby DSD » Sat Oct 20, 2012 11:11 pm

Selcal wrote:Thanks :)

I've tried the restart, and the direct IP (remote and over VPN with a local address).

I'll try to get the logs over the weekend, more to come!


What version of XBMC are you running?
Some of the transcoding formats are not properly supported in XBMC 11.
HSL transcoding is among the once not supported before version 12 of XBMC and also RTP is a bit unstable in XBMC 11.
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

Re: Dvblink for XBMC

Postby Selcal » Sun Oct 21, 2012 2:50 pm

That's the key!

Under XMBC 12a5 it works fine. Thanks! :)
Selcal
 
Posts: 35
Joined: Thu Dec 11, 2008 4:42 pm

Re: Dvblink for XBMC

Postby DSD » Sun Oct 21, 2012 3:40 pm

Selcal wrote:That's the key!

Under XMBC 12a5 it works fine. Thanks! :)

I'm glad it helped. :)
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

Re: Dvblink for XBMC

Postby spaceboy » Sun Nov 04, 2012 2:20 pm

hi DSD, do you have any interest in updating this for the latest versions of xbmc as its the only solution available for the pi but the latest version of raspbmc seems to have killed the script, a recent windows nightly doesn't work either with the following two key lines in the log:

12:45:02 T:7672 ERROR: EXCEPTION: argument "iconImage" for method "XBMCAddon::xbmcgui::ListItem" must be unicode or str
12:45:02 T:7672 ERROR: XFILE::CPluginDirectory::EndOfDirectory - called with an invalid handle.

other posts seem to link this to the plugin not being compatible with xmbc anymore. no problem if you don't want to do any more development, i'll just wait for the pvr build to be ported to the pi
spaceboy
 
Posts: 164
Joined: Tue Jul 20, 2010 6:30 pm

Re: Dvblink for XBMC

Postby DSD » Sun Nov 04, 2012 4:14 pm

spaceboy wrote:hi DSD, do you have any interest in updating this for the latest versions of xbmc as its the only solution available for the pi but the latest version of raspbmc seems to have killed the script, a recent windows nightly doesn't work either with the following two key lines in the log:

12:45:02 T:7672 ERROR: EXCEPTION: argument "iconImage" for method "XBMCAddon::xbmcgui::ListItem" must be unicode or str
12:45:02 T:7672 ERROR: XFILE::CPluginDirectory::EndOfDirectory - called with an invalid handle.

other posts seem to link this to the plugin not being compatible with xmbc anymore. no problem if you don't want to do any more development, i'll just wait for the pvr build to be ported to the pi

I will take a closer look when I get home.
Are you running the latest Raspmc?
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

Re: Dvblink for XBMC

Postby DSD » Sun Nov 04, 2012 7:53 pm

Try turning off the loading of channel logos.
This might fix the problem for now.

I'm not experiencing any errors when trying the plugin with the build of Raspmc from Oct 20th.

But I'll try and look into this when possible so it's possible to use channel logos again.
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

Re: Dvblink for XBMC

Postby spaceboy » Sun Nov 04, 2012 9:59 pm

hi DSD, thanks. no its not channel logos, they're already off. it works with eden but not the latest nightly that raspbmc is running nor the windows nightly of 2/11. cheers
spaceboy
 
Posts: 164
Joined: Tue Jul 20, 2010 6:30 pm

Re: Dvblink for XBMC

Postby DSD » Mon Nov 05, 2012 5:02 pm

spaceboy wrote:hi DSD, thanks. no its not channel logos, they're already off. it works with eden but not the latest nightly that raspbmc is running nor the windows nightly of 2/11. cheers

I'll try it on the latest nightly build on Windows and if I can reproduce the error I'll fix it.
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

Re: Dvblink for XBMC

Postby spaceboy » Tue Nov 06, 2012 7:32 pm

found anything?
spaceboy
 
Posts: 164
Joined: Tue Jul 20, 2010 6:30 pm

Re: Dvblink for XBMC

Postby DSD » Tue Nov 06, 2012 10:40 pm

spaceboy wrote:found anything?

I'm sorry to say that I''ve not been able to reproduce the error.
I even tried it on the daily build of today (XBMC 12.0-ALPHA7 Compiled Nov 6 1012) without any errors.

Is it possible for you to change to cache the channel list and then send me the channel list.
It's found under %appdata%\xbmc\addons\plugin.video.dvblink\resources\channels
and the file is "Channels.xml".

If I have your Channels.xml file then perhaps I can reproduce the error.
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

Re: Dvblink for XBMC

Postby spaceboy » Wed Nov 07, 2012 1:10 am

here's the channel.xml https://dl.dropbox.com/u/39548367/Channels.xml

would it be that though as it works fine under eden, but if i install todays build (6/11) the channel list loads and the working wheel starts but nothing plays. no error message, no other difference.

thanks
spaceboy
 
Posts: 164
Joined: Tue Jul 20, 2010 6:30 pm

Re: Dvblink for XBMC

Postby DSD » Wed Nov 07, 2012 9:35 pm

spaceboy wrote:here's the channel.xml https://dl.dropbox.com/u/39548367/Channels.xml

would it be that though as it works fine under eden, but if i install todays build (6/11) the channel list loads and the working wheel starts but nothing plays. no error message, no other difference.

thanks


That's strange it should work.
I'll take another look and see if I can find anything.
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

Re: Dvblink for XBMC

Postby DSD » Fri Nov 09, 2012 1:55 pm

Spaceboy are you using transcoding?
If you are, then try turning it off and test if the streaming works.
DSD
 
Posts: 188
Joined: Sun Jul 19, 2009 7:29 am

PreviousNext

Return to Development corner

Who is online

Users browsing this forum: No registered users and 5 guests

cron