Tuners missing after reboot

DVBLink TVSource is discussed here!

Tuners missing after reboot

Postby Bloody Typical » Tue May 30, 2017 2:57 pm

Hello.

Software: Server 6 Build:13310 & TV Source 6 Build:14061
Sources: HDHomeRun twin DVBt2 & MegaSat IP Server v3

Quick question:
When I have to power everything down due to a power cut I have a small issue when everything comes back online. TVSource seems to loose the Megasat tuners and I have to re-assign them in a specific way to not mess up my channel assignments.

The process I do is this:
Delete existing tuners 1 to 7
Reassign old Tuner 0 to new Tuner 0
Add new tuners 1 - 7 as a clone of Tuner 0

This is quiet odd as the Megasat has a static IP etc and the HDHomerun goes back without any problems but something must change for it to get seen as a new device, I've made sure to start the tuners first and allow them to boot before the DVBlink service starts.

This is not a huge issue just something to remember when restarting the whole lot, if I just restart the DVBLink service then everything is fine still, just when a reboot of the Megasat box is required then I have to do the process above.

This is probably just how the Megasat behaves but just wondered if there was a reason to it or a way to fix it?

I havn't got logs to post at the moment as the issue is rarely come accross.

Thanks.
Steve
Bloody Typical
 
Posts: 3
Joined: Tue May 30, 2017 2:16 pm


Re: Tuners missing after reboot

Postby the_man » Wed May 31, 2017 9:04 am

It looks like your sat2ip receiver does re-initialise tuners with another ids or receiver does not has a static ip ...
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Tuners missing after reboot

Postby Bloody Typical » Wed May 31, 2017 3:17 pm

Bingo, found a thread referencing changing UUID's on reboot on TVHeadEnd forums.

https://tvheadend.org/issues/4176

Will keep an eye on that as he's in contact with there support.

thanks
Bloody Typical
 
Posts: 3
Joined: Tue May 30, 2017 2:16 pm

Re: Tuners missing after reboot

Postby the_man » Thu Jun 01, 2017 2:48 pm

Bloody Typical wrote:Bingo, found a thread referencing changing UUID's on reboot on TVHeadEnd forums.

https://tvheadend.org/issues/4176

Will keep an eye on that as he's in contact with there support.

thanks

Please,keep us updated on this matter. Could be useful for other members.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Tuners missing after reboot

Postby Bloody Typical » Thu Aug 24, 2017 10:10 am

Just an update to this, the updated Megasat firmware stops new UUIDS being generated for the tuners.

Have tested to confirm this works ok now.
Bloody Typical
 
Posts: 3
Joined: Tue May 30, 2017 2:16 pm

Re: Tuners missing after reboot

Postby the_man » Mon Aug 28, 2017 11:22 am

Thanks)
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm


Return to DVBLink TVSource

Who is online

Users browsing this forum: No registered users and 6 guests