dvblink_server process leaking thread handles

General discussions over DVBLink products

dvblink_server process leaking thread handles

Postby toga » Sun Nov 09, 2014 11:33 am

I installed DVBLink 5.1 beta 1, and it works very well. A number of issues with version 5.0 seem to be fixed in 5.1. I’m using DVBLink Server (build 10701), Connect! Server (build 10759) and TVSource (build 10705) with a DVBSky S952 card on Windows Server 2012R2.

I see one serious issue is still in DVBLink 5.1 β 1 that was also in 5.0: The dvblink_server process is leaking handles, at a constant rate of about 250 handles per hour or about 6000 per day! See the attached screenshot from Windows performance monitor showing the handle count of dvblink_server process over ca. 40 hours. The small bumps are recordings that took place, but otherwise there is a linear rise of the handle count.

dvblink_server - Handles.png
dvblink_server - Handles.png (49.9 KiB) Viewed 2680 times


Using ‘Handle’ utility (from http://technet.microsoft.com/en-us/sysi ... s/bb896655) it can be seen that the leaked handles are all thread-handles. Since the number of executing threads doesn't increase, it seems that the leaked handles are from threads that have ended, but their handle was not closed.

For now I’m restarting the dvblink_server process about once per week, but it would be great if you could look into that issue and fix the leak. Please let me know if you need more information.
(I understand that Windows Server OS is not officially supported. OTOH, I don’t think that the handle leak depends on the OS flavor.)

Thanks in advance!
toga
 
Posts: 22
Joined: Sun Jun 29, 2014 10:48 am


Re: dvblink_server process leaking thread handles

Postby yamcenutzer » Mon Oct 26, 2015 7:56 pm

this thread is reaching it's first anniversary, so I thought it might be a good idea to say that this handle leak is still present in the current builds (5.5 whatever build number is curent today)
:-(
DVBLink TVSource 6, 4x DigitalDevices S2 Tuners, Win7x64, Dq77MK, e3-1225, 8GB, WMC local, WMC-remote, testing KODI usabilty for TV since 2012 - still failing...
yamcenutzer
 
Posts: 277
Joined: Fri Apr 20, 2012 1:53 pm


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest

cron