DVBLink server not very reliable

DVBLink TV Server for Ubuntu linux is discussed here!

DVBLink server not very reliable

Postby mortomanos » Thu Sep 29, 2016 4:44 am

I'm in the phase of testing DVBLink TV server with TVsource (not purchased yet, so with the trial license) and a DVB-S2 DVBSky 960 tuner on my Ubuntu 16.04.1 server.

There are several issues I've come up with and want to ask if anyone experienced similar problems. And I need help to solve my problems, as I am looking for a reliable solution to record DVB-S2 and DVB-T2 and watch them on different clients.

1) Installation went fine, including installing TVsource and activating the trial license
2) The DVBLink web server also works
3) After plugging the DVBSky 960 to the USB port (on a USB hub), the kernel recognized it, v4l was able to load the firmware, so it seemed to work
4) Configuring the DVB-S2 device was ok, I was able to find the Astra 19,2E channels, selected some of them for using, downloaded and installed the TV logos and associated a XMLTV source. So from this point of view the system seemed to be in a good shape.
5) I also configured a recording path with enough storage
6) I tried to record some TV shows. Sometimes this worked, sometimes this did not work. The recording always started and created a file with 0 Bytes. In some cases, there was no data from the tuner (because the bitrate in the monitoring section of the web server stayed at 0). Nothing was recorded, and an error message showed up in the log file:
Code: Select all
[E] active_recording: Generated thumbnail for (7-10110000-1475083500) is invalid and deleted

7) After manually selecting a channel in the web client to see its stream, in some cases, the stream appeared, with additional errors in the log file:
Code: Select all
[E] memory_buffer_sender::handle_write callback: encountered error sending response data: 32 Broken pipe!!!!!!!!

8) Typically, starting a recording after I saw a TV stream output in the web client went ok. The recording was done, and had file size > 0 bytes (content). I was able to see the recording on several clients (Apple TV, web client).
9) I started to play around with recording some TV shows to see where the error of "empty recordings" come from. But with no success, there was no pattern I could find, when a show was recorded properly, and when the recording contained nothing.

I don't see any error messages in dmesg or syslog, that the tuner device did not work properly. The only error messages I see in the dvblink_server.log file are shown in this post.

So here are my questions:

+ has anyone experienced something like that?
+ how can I debug this in a way that the support team is able to help me?

Two more thoughts:

- Testing with the DVBLink client for MacOS resulted in segmentation faults on the server side, though. I was only able to restart the server with "restart" (I think because of the pid file that stayed there), not with "start". After restarting the server and reusing the client again, the segfault occurred once more. So i stopped using the MacOS client. The clients on Apple TV and iPhone worked without errors so far.
- After activating the trial license of the TVsource package, the result was "12 days left". On the dvblogic web page there is mentioned a trial period of 20 days. I don't know why I got 12 days only.

Please help.
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am


Re: DVBLink server not very reliable

Postby mortomanos » Thu Sep 29, 2016 6:01 am

Addendum: still unreliable, after a few more scheduled recordings. Some work, some don't. No pattern so far.

My environment:

Code: Select all
# dpkg -l dvblink*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                          Version             Architecture        Description
+++-=============================-===================-===================-===============================================================
ii  dvblink-server                6.0.0               amd64               TV that's always with you!
# for i in /opt/DVBLink/*/version; do echo -n "$i: "; cat $i; done
/opt/DVBLink/channel_files/version: 13129
/opt/DVBLink/common/version: 13129
/opt/DVBLink/transponders/version: 13109


Code: Select all
# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.1 LTS"


I tried to raise the debug level to "information", but there was no useful output in it.
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am

Re: DVBLink server not very reliable

Postby mortomanos » Fri Sep 30, 2016 5:47 am

After some more testing it looks as if it only works if I "wake up" the tuner device using a direct stream (by clicking on the channel name, to get the live picture). Then some scheduled recordings (2-3, on different channels) work. But not all of them, some of the scheduled recordings result in 0 bytes written on disk.

I'm wondering if there are some 4vl commands to test if there is signal output, and to somehow reset the device.
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am

Re: DVBLink server not very reliable

Postby mortomanos » Fri Sep 30, 2016 6:06 am

Another observation: sometimes the server is able to generate a thumbnail, even if the recorded TV show has 0 bytes. So there must be a tuner signal somehow, but the writing on the disk fails.
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am

Re: DVBLink server not very reliable

Postby the_man » Fri Sep 30, 2016 2:43 pm

In order to give you a clear answer, need to check a full log files form the dvblink server.

Please, set log level to info restart dvblink server, reproduce the issue and attach zipped log files here.
http://dvblogic.com/wiki/index.php/How_ ... _log_files
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: DVBLink server not very reliable

Postby mortomanos » Fri Sep 30, 2016 5:37 pm

Of course I can do that:

dvblink-log-20160930-1831.zip
(72.18 KiB) Downloaded 75 times


As I said before, I found nothing useful in the logs, but maybe there is something hidden. I tested with a few scheduled recordings, and when downloading the log files I got 3 recordings with 0 bytes and 1 recording with data. The first 3 recordings had no thumbnail created, the one with data did generate a thumbnail.
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am

Re: DVBLink server not very reliable

Postby the_man » Mon Oct 03, 2016 11:18 am

You do have a one TVSource and you have set a recordings which are intersected by time form the channels (mostly) form different transponders.
Please set the timers from: 3sat, KiKA, ZDF
All at the same time. And go to Monitoring tab at the configuration page. Do you see a bitrate on all the channels?
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: DVBLink server not very reliable

Postby mortomanos » Sun Oct 09, 2016 12:33 pm

I did a completely fresh installation, then I tried with two recordings on 3sat and KiKA (almost the same time), on monitoring tab the bitrate for both is zero.

I also tried once again getting the TechnoTrend CT2-4650 to function properly, but with no result. There are no TV channels found on this tuner. Tested this with the TechnoTrend drivers and program on a Windows host, where it worked.

My license will expire today, it said "12 days left" after activating, even if there was something like 20 days promised on the web site. So maybe I'm not able to test any more, unless I'll get a license for TVsource. But will there be more support on the forum to get my problems solved?
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am

Re: DVBLink server not very reliable

Postby mortomanos » Sun Oct 09, 2016 3:27 pm

Recording KiKA, 3sat and ZDF the same time also does not work. No bitrate at all.
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am

Re: DVBLink server not very reliable

Postby mortomanos » Sun Oct 09, 2016 4:07 pm

Find attached the logs of the recordings in parallel.

dvblink-log-20161009-1706.zip
(32.78 KiB) Downloaded 76 times
mortomanos
 
Posts: 13
Joined: Thu Sep 29, 2016 4:22 am

Re: DVBLink server not very reliable

Postby the_man » Mon Oct 10, 2016 10:05 am

Write to info@dvblogic.com in order to get another trial period for tests.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm


Return to DVBLink TV server for Ubuntu linux

Who is online

Users browsing this forum: No registered users and 1 guest