[W] broker::start_recorder(): recorder is not found!!!

DVBLink TV Server for Ubuntu linux is discussed here!

[W] broker::start_recorder(): recorder is not found!!!

Postby jawilljr » Tue Feb 23, 2016 11:54 am

For some reason I am now getting the error "[W] broker::start_recorder(): recorder is not found!!!" when I stop/start the dvblink server.

Below is the output on the terminal when I start the server:

Code: Select all
2016-Feb-23 04:36:07:   
2016-Feb-23 04:36:07:   ==============================================================
2016-Feb-23 04:36:07:                      Logging is started
2016-Feb-23 04:36:07:   ==============================================================
2016-Feb-23 04:36:07:   [I] DVBLink server product id: 645fdfdb-a450-11e3-a88c-005056c00008
2016-Feb-23 04:36:07:   [I] ---------------------------
2016-Feb-23 04:36:07:   [I] Installed DVBLink products:
2016-Feb-23 04:36:07:   [I] DVBLink TVSource, 5.5.0, 12217
2016-Feb-23 04:36:07:   [I] DVBLink EPG Loader for PercData, 5.5.0, 11943
2016-Feb-23 04:36:07:   [I] DVBLink Server, 5.5.0, 12350
2016-Feb-23 04:36:07:   [I] ---------------------------
2016-Feb-23 04:36:07:   [W] broker::start_recorder(): recorder is not found!!!
/usr/local/bin/dvblink/web_server/addons/connect_server/__init__.py:145: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
/usr/local/bin/dvblink/web_server/addons/connect_server/__init__.py:195: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6


I also can not access the webui. I get "internal error" when I try to open the webui.

I am attaching the server log and web server log.
Attachments
dvblinklogs.zip
(155.27 KiB) Downloaded 104 times
jawilljr
 
Posts: 21
Joined: Fri Apr 17, 2015 3:37 pm


Re: [W] broker::start_recorder(): recorder is not found!!!

Postby the_man » Tue Feb 23, 2016 2:30 pm

Go to DVBLink folder -> share/database/ rename the current dlrecorder.db to back_dlrecorder.db
try to start dvblink server once more.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby jawilljr » Tue Feb 23, 2016 2:47 pm

nogo...same errors.
jawilljr
 
Posts: 21
Joined: Fri Apr 17, 2015 3:37 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby the_man » Tue Feb 23, 2016 2:52 pm

Try to do an update of the server.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby the_man » Tue Feb 23, 2016 2:53 pm

And after that, new log files, please.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby jawilljr » Tue Feb 23, 2016 2:57 pm

the_man wrote:Try to do an update of the server.


Do you mean reinstall the server? On the DVBLogic download page for Ubuntu has the same build number that I am running.
jawilljr
 
Posts: 21
Joined: Fri Apr 17, 2015 3:37 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby the_man » Tue Feb 23, 2016 3:00 pm

Install the server over the current one. Maybe just some corruption in the config files.

Also please check whether the dvblink_configuration.xml file is not empty.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby jawilljr » Tue Feb 23, 2016 3:05 pm

the_man wrote:Install the server over the current one. Maybe just some corruption in the config files.

Also please check whether the dvblink_configuration.xml file is not empty.


That file is empty.
jawilljr
 
Posts: 21
Joined: Fri Apr 17, 2015 3:37 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby the_man » Tue Feb 23, 2016 3:09 pm

Oh, in that case only the fresh install will help.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby the_man » Tue Feb 23, 2016 3:11 pm

You can try to make an update(repair) of the server. But i have faced with this issue a few times before, and as i remember the only way a clean install was the way out.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby the_man » Tue Feb 23, 2016 3:13 pm

If you have a dvblink server backup file, then the reinstalling will be quite fast and easy.
http://dvblogic.com/wiki/index.php/How_ ... nd_restore
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: [W] broker::start_recorder(): recorder is not found!!!

Postby jawilljr » Tue Feb 23, 2016 4:02 pm

Looks I got it working again.

I uninstalled then reinstalled the server. That got the webui working again.

I of course had to reinstall the TVSource and PercData addons and reconfigure everything.

What is nice is my registration files did not get corrupted...the products page says they are both registered...nice.

Anyway thank you for your help and patience.
jawilljr
 
Posts: 21
Joined: Fri Apr 17, 2015 3:37 pm


Return to DVBLink TV server for Ubuntu linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron