Transcoding - select audio stream

DVBLink TV Server for Ubuntu linux is discussed here!

Transcoding - select audio stream

Postby mardibloke » Tue Apr 07, 2015 1:36 pm

Some BBC HD Freesat channels the default (first) audio stream is for NAR (narrated audio), and the second audio stream is what I want.

I think that when using the server transcoder, i'm only getting the NAR audio stream.

When I don't use the server transcoder my client (openelec) can select either audio stream.

Is there any way the server transcoder can be configured to select a preferred audio stream, per TV channel?

- --
Rod, UK
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm


Re: Transcoding - select audio stream

Postby the_man » Thu Apr 09, 2015 2:34 pm

Yes, you can select needed audio stream in DVBLink PVR options. Just enter language like on screenshot and if this audio track exists it will be selected.
Attachments
Screenshot-164.jpg
Screenshot-164.jpg (68.86 KiB) Viewed 13197 times
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Transcoding - select audio stream

Postby mardibloke » Fri Apr 10, 2015 1:56 pm

Thanks, we poked around the setting you pointed to, without much success, we still get the NAR stream with transcoding enabled.

With transcoding disabled in the Add-On, I see two audio streams

Stream 1 - is the one we don't want:

Image

Image

Stream 2 - is the one we want for this channel

Image

Image

From the above, what do you suggest we put into the box for 'Audio Track' in the PVR Add-on.

Also when we do this, how will impact other TV Channels, as for most channels they are working ok now.

Thanks

- --
Rod, UK
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm

Re: Transcoding - select audio stream

Postby the_man » Fri Apr 10, 2015 2:17 pm

Strange, i have doublechecked it and it work great for me.
(I have tested audio streams with Euronews channel, because i know that there are 10 audiostreams and all 10 streams work great with enabled transcoding. But be sure that you wrote Audio track name exactly at PVR Addon-> stream tab )
In that case all channels would play with English audio, if there is no English stream for channel, it would play first audio track from list (in your case "Nar")
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Transcoding - select audio stream

Postby the_man » Fri Apr 10, 2015 2:18 pm

What version of PVR addon do you use?
The latest is 1.9.13
viewtopic.php?f=66&t=28989
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Transcoding - select audio stream

Postby mardibloke » Fri Apr 10, 2015 2:30 pm

Thanks again for checking.

We are on 1.9.13 - have tried 3 different PC's

In PVR Add-on stream settings we have tried : English, Eng, eng, AC3, English - AC3

For my channel in the screen shots above, should it be the - English - AC3 (like I see in name when not transcoding for the audio stream), or eng ?

- --
Rod, UK
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm

Re: Transcoding - select audio stream

Postby the_man » Fri Apr 10, 2015 2:35 pm

As i know you must enter only three chars, like in dvblink web-client for the transcoded stream
Attachments
Screenshot-166.jpg
Screenshot-166.jpg (180.22 KiB) Viewed 13157 times
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Transcoding - select audio stream

Postby Oberon » Fri Apr 10, 2015 2:38 pm

If you can record a minute of the stream with DVBLink and then open it in TSReader - what are the language tags of audio streams that you see there?
Oberon
 
Posts: 11763
Joined: Thu Sep 06, 2007 5:04 am

Re: Transcoding - select audio stream

Postby mardibloke » Fri Apr 10, 2015 2:59 pm

Do you have a recommendation for something like TSReader than runs on Ubuntu?

Here is what a recorded file looks like in VLC
Image

Here you can download a recording:

https://dl.dropboxusercontent.com/u/124 ... cording.ts

- --
Rod, UK
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm

Re: Transcoding - select audio stream

Postby Oberon » Fri Apr 10, 2015 3:07 pm

Set message level to 2 in Messages window of VLC, start playing file and paste here Messages window output.
Oberon
 
Posts: 11763
Joined: Thu Sep 06, 2007 5:04 am

Re: Transcoding - select audio stream

Postby mardibloke » Fri Apr 10, 2015 3:27 pm

Thanks, sorry for the long post, hope this helps.....

Code: Select all
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
core debug: processing request item: E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts, node: Playlist, skip: 0
core debug: resyncing on E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts
core debug: E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts is at 0
core debug: starting playback of the new playlist item
core debug: resyncing on E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts
core debug: E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts is at 0
core debug: creating new input thread
core debug: Creating an input for 'E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts'
core debug: requesting art for E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts
core debug: using timeshift granularity of 50 MiB, in path '/tmp'
core debug: `file:///run/user/1000/gvfs/smb-share%3Aserver%3Drodsnas1.local%2Cshare%3Drecordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts' gives access `file' demux `' path `/run/user/1000/gvfs/smb-share%3Aserver%3Drodsnas1.local%2Cshare%3Drecordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts'
core debug: specified demux `any'
core debug: creating demux: access='file' demux='any' location='/run/user/1000/gvfs/smb-share%3Aserver%3Drodsnas1.local%2Cshare%3Drecordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts' file='/run/user/1000/gvfs/smb-share:server=rodsnas1.local,share=recordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts'
core debug: looking for access_demux module matching "file": 21 candidates
core debug: looking for meta fetcher module matching "any": 1 candidates
qt4 debug: IM: Setting an input
lua debug: Trying Lua scripts in /home/rod/.local/share/vlc/lua/meta/fetcher
lua debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/fetcher
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/fetcher/tvrage.luac
core debug: no access_demux modules matched
core debug: creating access 'file' location='/run/user/1000/gvfs/smb-share%3Aserver%3Drodsnas1.local%2Cshare%3Drecordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts', path='/run/user/1000/gvfs/smb-share:server=rodsnas1.local,share=recordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts'
core debug: looking for access module matching "file": 25 candidates
filesystem debug: opening file `/run/user/1000/gvfs/smb-share:server=rodsnas1.local,share=recordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts'
lua debug: skipping script (unmatched scope) /usr/lib/vlc/lua/meta/fetcher/tvrage.luac
lua debug: Trying Lua scripts in /usr/share/vlc/lua/meta/fetcher
core debug: no meta fetcher modules matched
core debug: searching art for E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts
core debug: looking for art finder module matching "any": 2 candidates
core debug: using access module "filesystem"
core debug: Using stream method for AStream*
core debug: starting pre-buffering
core debug: received first data after 0 ms
core debug: pre-buffering done 1024 bytes in 0s - 166666 KiB/s
core debug: looking for stream_filter module matching "any": 9 candidates
core debug: no stream_filter modules matched
core debug: looking for stream_filter module matching "record": 9 candidates
core debug: using stream_filter module "record"
core debug: creating demux: access='file' demux='any' location='/run/user/1000/gvfs/smb-share%3Aserver%3Drodsnas1.local%2Cshare%3Drecordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts' file='/run/user/1000/gvfs/smb-share:server=rodsnas1.local,share=recordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts'
core debug: looking for demux module matching "any": 65 candidates
mod debug: MOD validation failed (ext=ts)
lua debug: Trying Lua scripts in /home/rod/.local/share/vlc/lua/meta/art
lua debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/art
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/00_musicbrainz.luac
lua debug: skipping script (unmatched scope) /usr/lib/vlc/lua/meta/art/00_musicbrainz.luac
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/01_googleimage.luac
lua debug: skipping script (unmatched scope) /usr/lib/vlc/lua/meta/art/01_googleimage.luac
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/02_frenchtv.luac
lua debug: skipping script (unmatched scope) /usr/lib/vlc/lua/meta/art/02_frenchtv.luac
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/03_lastfm.luac
lua debug: skipping script (unmatched scope) /usr/lib/vlc/lua/meta/art/03_lastfm.luac
lua debug: Trying Lua scripts in /usr/share/vlc/lua/meta/art
core debug: no art finder modules matched
core debug: looking for meta fetcher module matching "any": 1 candidates
lua debug: Trying Lua scripts in /home/rod/.local/share/vlc/lua/meta/fetcher
lua debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/fetcher
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/fetcher/tvrage.luac
core debug: using meta fetcher module "lua"
core debug: removing module "lua"
core debug: searching art for E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts
core debug: looking for art finder module matching "any": 2 candidates
lua debug: Trying Lua scripts in /home/rod/.local/share/vlc/lua/meta/art
lua debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/art
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/00_musicbrainz.luac
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/01_googleimage.luac
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/02_frenchtv.luac
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/03_lastfm.luac
lua debug: Trying Lua scripts in /usr/share/vlc/lua/meta/art
core debug: no art finder modules matched
core debug: art not found for E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts
ts debug: pid[5300] unknown
ts debug: pid[5302] unknown
ts debug: pid[261] unknown
ts debug: PATCallBack called
ts debug: new PAT ts_id=1068 version=5 current_next=1
ts debug: * number=1068 pid=261
ts debug: pid[16] unknown
ts debug: PSINewTableCallBack: table 0x42(66) ext=0x42c(1068)
ts debug: SDTCallBack called
ts debug: new SDT ts_id=1068 version=29 current_next=1 network_id=1068
ts debug: * service id=1068 eit schedule=1 present=1 running=0 free_ca=0
ts debug: - type=62 provider= name=
core debug: EsOutProgramMeta: number=1068
core debug: selecting program id=1068
ts debug: pid[5303] unknown
ts debug: PMTCallBack called
ts debug: new PMT program number=1068 version=1 pid_pcr=5300
ts debug: * es pid=5300 type=27 dr->i_tag=0x6
ts debug: * es pid=5300 type=27 dr->i_tag=0x52
ts debug: * es pid=5300 type=27 dr->i_tag=0xf
ts debug: * es pid=5300 type=27 dr->i_tag=0xfe
ts debug: * es pid=5300 type=27 fcc=h264
ts debug: * es pid=5302 type=3 dr->i_tag=0xa
ts debug: * es pid=5302 type=3 dr->i_tag=0xf
ts debug: * es pid=5302 type=3 dr->i_tag=0xfe
ts debug: * es pid=5302 type=3 dr->i_tag=0x52
ts debug: found language: NAR
ts debug: * es pid=5302 type=3 fcc=mpga
ts debug: * es pid=5303 type=6 dr->i_tag=0xf
ts debug: * es pid=5303 type=6 dr->i_tag=0x56
ts debug: * es pid=5303 type=6 dr->i_tag=0xfe
ts debug: * es pid=5303 type=6 dr->i_tag=0x52
ts debug: * ttxt type=Teletext subtitles lan=eng page=888
ts debug: * ttxt type=Teletext lan=eng page=888
ts debug: * Stream Component Identifier: 4
ts debug: * es pid=5303 type=6 fcc=telx
ts debug: * es pid=3845 type=11 dr->i_tag=0x52
ts debug: * es pid=3845 type=11 *unknown*
ts debug: * es pid=3846 type=11 dr->i_tag=0x52
ts debug: * es pid=3846 type=11 *unknown*
ts debug: * es pid=3847 type=11 dr->i_tag=0x13
ts debug: * es pid=3847 type=11 dr->i_tag=0x66
ts debug: * es pid=3847 type=11 dr->i_tag=0x52
ts debug: * es pid=3847 type=11 *unknown*
ts debug: * es pid=5304 type=6 dr->i_tag=0xf
ts debug: * es pid=5304 type=6 dr->i_tag=0x59
ts debug: * es pid=5304 type=6 dr->i_tag=0xfe
ts debug: * es pid=5304 type=6 dr->i_tag=0x52
ts debug: * Stream Component Identifier: 5
ts debug: * es pid=5304 type=6 fcc=dvbs
ts debug: * es pid=2321 type=5 dr->i_tag=0x52
ts debug: * es pid=2321 type=5 dr->i_tag=0xf
ts debug: * es pid=2321 type=5 dr->i_tag=0x90
ts debug: * es pid=2321 type=5 dr->i_tag=0xfe
ts debug: * es pid=2321 type=5 *unknown*
ts debug: * es pid=2322 type=5 dr->i_tag=0x52
ts debug: * es pid=2322 type=5 dr->i_tag=0xf
ts debug: * es pid=2322 type=5 dr->i_tag=0x90
ts debug: * es pid=2322 type=5 dr->i_tag=0xfe
ts debug: * es pid=2322 type=5 *unknown*
ts debug: * es pid=2323 type=5 dr->i_tag=0x52
ts debug: * es pid=2323 type=5 dr->i_tag=0xf
ts debug: * es pid=2323 type=5 dr->i_tag=0x90
ts debug: * es pid=2323 type=5 dr->i_tag=0xfe
ts debug: * es pid=2323 type=5 *unknown*
ts debug: * es pid=3840 type=5 dr->i_tag=0x52
ts debug: * es pid=3840 type=5 dr->i_tag=0x5f
ts debug: * es pid=3840 type=5 dr->i_tag=0xd1
ts debug: * es pid=3840 type=5 *unknown*
ts debug: * es pid=3841 type=5 dr->i_tag=0x52
ts debug: * es pid=3841 type=5 dr->i_tag=0x5f
ts debug: * es pid=3841 type=5 dr->i_tag=0xd1
ts debug: * es pid=3841 type=5 *unknown*
ts debug: * es pid=3842 type=5 dr->i_tag=0x52
ts debug: * es pid=3842 type=5 dr->i_tag=0x5f
ts debug: * es pid=3842 type=5 dr->i_tag=0xd1
ts debug: * es pid=3842 type=5 *unknown*
ts debug: * es pid=3843 type=5 dr->i_tag=0x52
ts debug: * es pid=3843 type=5 dr->i_tag=0x5f
ts debug: * es pid=3843 type=5 dr->i_tag=0xd1
ts debug: * es pid=3843 type=5 *unknown*
ts debug: * es pid=3844 type=5 dr->i_tag=0x52
ts debug: * es pid=3844 type=5 dr->i_tag=0x5f
ts debug: * es pid=3844 type=5 dr->i_tag=0xd1
ts debug: * es pid=3844 type=5 *unknown*
ts debug: * es pid=5301 type=6 dr->i_tag=0x52
ts debug: * es pid=5301 type=6 dr->i_tag=0xa
ts debug: * es pid=5301 type=6 dr->i_tag=0xf
ts debug: * es pid=5301 type=6 dr->i_tag=0x6a
ts debug: * es pid=5301 type=6 dr->i_tag=0xfe
ts debug: * Stream Component Identifier: 8
ts debug: found language: eng
ts debug: * es pid=5301 type=6 fcc=a52
ts debug: * es pid=2328 type=5 dr->i_tag=0x52
ts debug: * es pid=2328 type=5 dr->i_tag=0x74
ts debug: * es pid=2328 type=5 *unknown*
ts debug: * es pid=2329 type=5 dr->i_tag=0x52
ts debug: * es pid=2329 type=5 dr->i_tag=0xf
ts debug: * es pid=2329 type=5 dr->i_tag=0x90
ts debug: * es pid=2329 type=5 dr->i_tag=0xfe
ts debug: * es pid=2329 type=5 *unknown*
core debug: using demux module "ts"
core debug: looking for a subtitle file in /run/user/1000/gvfs/smb-share:server=rodsnas1.local,share=recordedtv/
core debug: looking for decoder module matching "any": 42 candidates
avcodec debug: CPU flags: 0x000053db
avcodec debug: trying to use direct rendering
avcodec debug: allowing 4 thread(s) for decoding
avcodec debug: avcodec codec (H264 - MPEG-4 AVC (part 10)) started
avcodec debug: using frame thread mode with 4 threads
core debug: using decoder module "avcodec"
core debug: looking for packetizer module matching "any": 23 candidates
core debug: using packetizer module "packetizer_h264"
core debug: looking for decoder module matching "any": 42 candidates
core debug: using decoder module "mpeg_audio"
ts debug: DEMUX_SET_GROUP 0 (nil)
core debug: looking for meta reader module matching "any": 2 candidates
lua debug: Trying Lua scripts in /home/rod/.local/share/vlc/lua/meta/reader
lua debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/reader
lua debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/reader/filename.luac
lua debug: Trying Lua scripts in /usr/share/vlc/lua/meta/reader
core debug: no meta reader modules matched
core debug: `file:///run/user/1000/gvfs/smb-share%3Aserver%3Drodsnas1.local%2Cshare%3Drecordedtv/E04-Little_Charley_Bear-1445_20150410-30-10680000-1428673500.ts' successfully opened
ts warning: first packet for pid=5300 cc=0xf
ts warning: first packet for pid=5302 cc=0x6
core debug: Buffering 0%
ts warning: first packet for pid=5303 cc=0x4
ts warning: first packet for pid=3845 cc=0xb
core debug: Buffering 11%
core debug: Buffering 23%
ts warning: first packet for pid=3846 cc=0xd
core debug: Buffering 35%
core debug: Buffering 46%
core debug: Buffering 58%
mpeg_audio debug: MPGA channels:2 samplerate:48000 bitrate:256
core debug: reusing audio output
pulse debug: using stereo channel map
core debug: Buffering 70%
core debug: Buffering 81%
packetizer_h264 warning: waiting for SPS/PPS
ts warning: first packet for pid=3847 cc=0xe
packetizer_h264 debug: found NAL_SPS (sps_id=0)
packetizer_h264 debug: found NAL_PPS (pps_id=0 sps_id=0)
packetizer_h264 debug: Seen SEI recovery point, 0 recovery frames
core debug: Buffering 93%
packetizer_h264 debug: Recovery from SEI recovery point complete
core debug: Stream buffering done (315 ms in 6 ms)
avcodec debug: available hardware decoder output format 53 (vaapi_vld)
avcodec debug: available hardware decoder output format 109 (vdpau)
avcodec debug: available software decoder output format 0 (yuv420p)
core debug: looking for hw decoder module matching "any": 4 candidates
pulse debug: changed buffer metrics: maxlength=4194304, tlength=46080, prebuf=0, minreq=15360
pulse debug: connected to sink alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo
core debug: output 'f32l' 44100 Hz Stereo frame=1 samples/8 bytes
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
core debug: looking for audio volume module matching "any": 2 candidates
core debug: using audio volume module "float_mixer"
core debug: input 'mpga' 48000 Hz Stereo frame=1152 samples/1161 bytes
core debug: looking for audio filter module matching "scaletempo": 14 candidates
scaletempo debug: format: 48000 rate, 2 nch, 4 bps, fl32
scaletempo debug: params: 30 stride, 0.200 overlap, 14 search
scaletempo debug: 1.000 scale, 1440.000 stride_in, 1440 stride_out, 1152 standing, 288 overlap, 672 search, 2400 queue, fl32 mode
core debug: using audio filter module "scaletempo"
core debug: conversion: 'mpga'->'f32l' 48000 Hz->48000 Hz Stereo->Stereo
core debug: looking for audio converter module matching "any": 12 candidates
core debug: no audio converter modules matched
core debug: looking for audio converter module matching "any": 12 candidates
mpgatofixed32 debug: mpga->f32l, bits per sample: 32
core debug: using audio converter module "mpgatofixed32"
core debug: conversion pipeline complete
core debug: conversion: 'f32l'->'f32l' 48000 Hz->48000 Hz Stereo->Stereo
core debug: conversion pipeline complete
core debug: looking for audio resampler module matching "any": 3 candidates
core debug: using audio resampler module "samplerate"
core debug: End of audio preroll
core debug: Decoder wait done in 2 ms
pulse debug: cannot synchronize start
pulse debug: deferring start (169410 us)
ts warning: first packet for pid=2321 cc=0xc
pulse debug: deferring start (145052 us)
pulse debug: deferring start (120580 us)
pulse debug: deferring start (96123 us)
pulse debug: deferring start (71627 us)
pulse debug: deferring start (47037 us)
pulse debug: deferring start (22589 us)
pulse warning: starting late (-1855 us)
core warning: playback way too early (-165649): playing silence
core debug: inserting 7305 zeroes
pulse debug: started
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
vdpau_avcodec debug: video surface limits: 4096x4096
vdpau_avcodec debug: decoder profile limits: level 41 mb 65536 4032x4080
core debug: using hw decoder module "vdpau_avcodec"
ts warning: first packet for pid=5304 cc=0xb
ts warning: first packet for pid=2323 cc=0xc
avcodec info: Using NVIDIA VDPAU Driver Shared Library 331.113 Mon Dec 1 20:28:22 PST 2014 for hardware decoding.
core debug: looking for text renderer module matching "any": 2 candidates
freetype debug: Building font databases.
freetype debug: Took 0 microseconds
freetype debug: Using Serif Bold as font from file /usr/share/fonts/truetype/dejavu/DejaVuSans.ttf
freetype debug: Using Monospace as mono-font from file /usr/share/fonts/truetype/dejavu/DejaVuSansMono.ttf
freetype debug: using fontsize: 2
core debug: using text renderer module "freetype"
core debug: looking for video filter2 module matching "any": 63 candidates
swscale debug: 32x32 (32x32) chroma: YUVA -> 16x16 (16x16) chroma: RGBA with scaling using Bicubic (good quality)
core debug: using video filter2 module "swscale"
core debug: looking for video filter2 module matching "any": 63 candidates
yuvp debug: YUVP to YUVA converter
core debug: using video filter2 module "yuvp"
core debug: Deinterlacing available
core debug: deinterlace 0, mode blend, is_needed 0
core debug: Opening vout display wrapper
core debug: looking for vout display module matching "any": 15 candidates
core debug: looking for vout window xid module matching "qt4,any": 4 candidates
qt4 debug: requesting video window...
qt4 debug: Video was requested 0, 0
core debug: using vout window xid module "qt4"
core debug: looking for inhibit module matching "any": 2 candidates
dbus_screensaver debug: found service org.freedesktop.ScreenSaver
core debug: using inhibit module "dbus_screensaver"
xcb debug: connected to X11.0 server
xcb debug: vendor : The X.Org Foundation
xcb debug: version: 11600000
xcb debug: using screen 0x300
vdpau_display debug: using back-end NVIDIA VDPAU Driver Shared Library 331.113 Mon Dec 1 20:28:22 PST 2014
vdpau_display debug: using RGBA format 2
vdpau_display debug: using X11 window 0x07c00001
ts warning: first packet for pid=3841 cc=0x9
ts warning: first packet for pid=3843 cc=0xb
core debug: VoutDisplayEvent 'fullscreen' 0
core debug: VoutDisplayEvent 'resize' 1920x1097 window
core debug: using vout display module "vdpau_display"
core debug: A filter to adapt decoder to display is needed
core debug: looking for video filter2 module matching "any": 63 candidates
core debug: using video filter2 module "vdpau_chroma"
core debug: Filter 'VDPAU' (0x7f02642c07d8) appended to chain
core debug: original format sz 1920x1088, of (0,0), vsz 1920x1080, 4cc VDV0, sar 1:1, msk r0x0 g0x0 b0x0
core debug: removing module "freetype"
core debug: looking for text renderer module matching "any": 2 candidates
freetype debug: Building font databases.
freetype debug: Took 0 microseconds
freetype debug: Using Serif Bold as font from file /usr/share/fonts/truetype/dejavu/DejaVuSans.ttf
freetype debug: Using Monospace as mono-font from file /usr/share/fonts/truetype/dejavu/DejaVuSansMono.ttf
freetype debug: using fontsize: 2
core debug: using text renderer module "freetype"
core debug: End of video preroll
freetype error: Breaking unbreakable line
vdpau_chroma debug: using video mixer temporal-spatial deinterlace feature
vdpau_chroma debug: using video mixer sharpness feature
vdpau_chroma debug: using video mixer 29
ts warning: first packet for pid=3842 cc=0x2
core debug: Detected interlaced video
core debug: deinterlace 0, mode blend, is_needed 1
core warning: VoutDisplayEvent 'pictures invalid'
core warning: VoutDisplayEvent 'pictures invalid'
vdpau_display debug: resetting pictures
ts warning: first packet for pid=5301 cc=0xe
ts warning: first packet for pid=3844 cc=0xd
core debug: Filter 0x7f02642c07d8 removed from chain
core debug: removing module "vdpau_chroma"
core debug: A filter to adapt decoder to display is needed
core debug: looking for video filter2 module matching "any": 63 candidates
core debug: using video filter2 module "vdpau_chroma"
core debug: Filter 'VDPAU' (0x7f02642c07d8) appended to chain
vdpau_chroma debug: using video mixer temporal-spatial deinterlace feature
vdpau_chroma debug: using video mixer sharpness feature
vdpau_chroma debug: using video mixer 29
vdpau_display debug: surface status: 2
xcb debug: display is visible
core warning: picture is too late to be displayed (missing 34 ms)
core debug: auto hiding mouse cursor
ts debug: PSINewTableCallBack: table 0x4e(78) ext=0x42c(1068)
ts warning: first packet for pid=2328 cc=0x5
ts debug: EITCallBack called
ts debug: new EIT service_id=1068 version=29 current_next=1 ts_id=1068 network_id=1068 segment_last_section_number=1 last_table_id=78
ts debug: * event id=36885 start_time:1428673500 duration=300 running=4 free_ca=1
ts debug: - short event lang=eng '†Little Charley Bear‡' : 'Big Little Charley: Charley is a teddy bear who uses his imagination to go on adventures. When Charley becomes a giant he finds there are a lot of fun things he can't do any more. [HD] [S]'
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x5f(95)
ts debug: - tag=0xcc(204)
ts debug: - tag=0xb4(180)
ts debug: * event id=36882 start_time:1428673800 duration=600 running=1 free_ca=1
ts debug: - short event lang=eng 'The †Numtums‡' : 'Picture Perfect: Number learning series. Bendy Go gets a delivery of a camera from cousin Kakadu who asks him to take a picture of the Numtums altogether. [HD] [S]'
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x50(80)
ts debug: - tag=0x5f(95)
ts debug: - tag=0xcc(204)
ts debug: - tag=0xb4(180)
core debug: EsOutProgramEpg: number=1068 name=Programme 1068
ts warning: first packet for pid=3840 cc=0xe
ts debug: eof ?
core debug: EOF reached
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
pulse debug: underflow
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: finished input
core debug: removing module "avcodec"
avcodec debug: ffmpeg codec (H264 - MPEG-4 AVC (part 10)) stopped
core debug: killing decoder fourcc `h264', 0 PES in FIFO
core debug: saving a free vout
core debug: reusing provided vout
qt4 debug: Qt: Fullscreen state changed
core debug: removing module "packetizer_h264"
core debug: removing module "mpeg_audio"
core debug: killing decoder fourcc `mpga', 0 PES in FIFO
core debug: removing module "samplerate"
core debug: removing module "mpgatofixed32"
core debug: removing module "scaletempo"
core debug: removing module "float_mixer"
core debug: keeping audio output
core debug: removing module "ts"
ts debug: pid list:
ts debug: - pid[0] seen
ts debug: - pid[16] seen
ts debug: - pid[17] seen
ts debug: - pid[18] seen
ts debug: - pid[261] seen
ts debug: - pid[2321] seen
ts debug: - pid[2323] seen
ts debug: - pid[2328] seen
ts debug: - pid[2329] seen
ts debug: - pid[3840] seen
ts debug: - pid[3841] seen
ts debug: - pid[3842] seen
ts debug: - pid[3843] seen
ts debug: - pid[3844] seen
ts debug: - pid[3845] seen
ts debug: - pid[3846] seen
ts debug: - pid[3847] seen
ts debug: - pid[5300] seen
ts debug: - pid[5301] seen
ts debug: - pid[5302] seen
ts debug: - pid[5303] seen
core debug: Program doesn't contain anymore ES
ts debug: - pid[5304] seen
ts debug: - pid[8191] seen
core debug: removing module "record"
core debug: removing module "filesystem"
core debug: dead input
core debug: changing item without a request (current 0/1)
core debug: nothing to play
core debug: destroying useless vout
core debug: Filter 0x7f02642c07d8 removed from chain
core debug: removing module "vdpau_chroma"
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
core debug: removing module "vdpau_display"
dbus_screensaver debug: got cookie 202311387
core debug: removing module "dbus_screensaver"
qt4 debug: releasing video...
qt4 debug: IM: Deleting the input
qt4 debug: Video is not needed anymore
core debug: removing module "freetype"
core debug: removing module "yuvp"
core debug: removing module "swscale"
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
pulse debug: changing sink 8: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo (Audio Codec Analogue Stereo)
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm

Re: Transcoding - select audio stream

Postby mardibloke » Tue Apr 14, 2015 5:55 pm

Wondered if you had time to look at this and/or need additional information from me.

- --
Rod, UK
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm

Re: Transcoding - select audio stream

Postby the_man » Wed Apr 15, 2015 7:51 am

From the log file i can see that English audio stream must work, but sorry at the moment i cann't understand why it isn't.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: Transcoding - select audio stream

Postby mardibloke » Wed Apr 15, 2015 10:54 am

Maybe its only related to us using OpenElec v5.0.8 (PVR Service says Kodi 14.2 Git: 7cc53a9 Compiled: Mar 31 2015), DVBLink PVR Client add-on is 1.9.13.

Its interesting that it works for you.

If I open a stream though the web interface - http://my.server.name:8100/tvguide/ - then click a channel name over on the left, to show Live TV stream - window opens and plays stream, right click on video and 'copy video location'
open VLC and choose Media/Open Network stream, and paste the link in I only get 1 audio stream, and its the eng one as expected (not NAR). So looks like the DVBLink Server transcoding settings are working great?

http://my.server.name:8101/dvblink/dire ... 84&lng=eng

You see eng in the link generated above.

For OpenElec/add-on its not selecting the eng audio stream for me still.

Perhaps I'm not the only one seeing this issue:

viewtopic.php?f=66&t=29536

Looks like other TV add-ons have had this challenge with the BBC HD channels NAR (visually impaired) audio stream, and have had to fix/update their code:

http://forum.kodi.tv/showthread.php?tid=181164

Thanks for any help/advice you can give.

- --
Rod, UK
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm

Re: Transcoding - select audio stream

Postby mardibloke » Sun Apr 19, 2015 3:34 pm

Thanks for your help via PM. I think you see the problem now.

Do you have anything else you need me to try/test?
mardibloke
 
Posts: 13
Joined: Tue Jun 15, 2010 5:09 pm

Next

Return to DVBLink TV server for Ubuntu linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron