EPG shows as not configured after adding URL to EPG sources

Post your questions about DVBLink products running on Windows platform here!

EPG shows as not configured after adding URL to EPG sources

Postby jsmith67 » Thu Mar 09, 2017 2:08 pm

EPG shows as not configured after adding URL to EPG sources XMLTV grabber. It does not download it automatically to my Directory. If I download the XML file manually from the URL and it to my directory it works but I need it to download automatically. Thanks for the help sorry if this has been answered I tried searching but couldn't find solution.

Windows 10 , DVBLink Server 6.0.0 and DVBLink for IPTV 6.0.0.

This is the error from the log.

xmltv_reader::download_file. cannot parse download url
jsmith67
 
Posts: 3
Joined: Thu Mar 09, 2017 1:52 pm


Re: EPG shows as not configured after adding URL to EPG sour

Postby the_man » Thu Mar 09, 2017 4:10 pm

It could be that the link you are using have some "unsupported" symbols, or maybe it is a link with the authorisation and it should be encoded.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: EPG shows as not configured after adding URL to EPG sour

Postby jsmith67 » Thu Mar 09, 2017 4:16 pm

Which symbols are unsupported? My link is like this

http://xxx-xx.xxx:xxxxx/xmltv.php?usern ... ord=xxxxxx

"Maybe it is a link with the authorisation and it should be encoded"

Sorry I don't understand what this means I am a bit of a beginner.
jsmith67
 
Posts: 3
Joined: Thu Mar 09, 2017 1:52 pm

Re: EPG shows as not configured after adding URL to EPG sour

Postby the_man » Thu Mar 09, 2017 4:57 pm

Please try to use the URL Encode for your XMLTV link, like this :
http://www.urlencoder.org/

Just encode this part:
username=xxxxxxxxxx@xxxxx.xxx&password=xxxxxx
and then add it to main part:
http://xxx-xx.xxx:xxxxx/xmltv.php?

(http://<one_part>?<encoded_part>)
And re-create Source once more.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: EPG shows as not configured after adding URL to EPG sour

Postby jsmith67 » Thu Mar 09, 2017 6:45 pm

Thanks. I encoded the URL and stopped getting the "cannot parse download URL" error but it still said not configured after saving, and it never downloaded the xml.
jsmith67
 
Posts: 3
Joined: Thu Mar 09, 2017 1:52 pm

Re: EPG shows as not configured after adding URL to EPG sour

Postby the_man » Fri Mar 10, 2017 11:48 am

I guess need to get a full log files. But better do not post it here (write to info@dvblogic.com)
Also try to set different types for downloaded link at the XMLTV settings.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm


Return to DVBLink Server on Windows platform

Who is online

Users browsing this forum: No registered users and 2 guests

cron