Server stops a few seconds after starting.

Post your questions about DVBLink products running on Windows platform here!

Server stops a few seconds after starting.

Postby SORCERER » Sun Jan 17, 2016 7:23 pm

I have installed and reinstalled countless times, but the server always shuts down after a few seconds.

My setup is:
Windows 10
DVBLink Server, 5.5.0, 12217
DVBLink TVSource, 5.5.0, 12217
3x Cinergy C PCI.

I have struggled with this issue for a while now, so all help solving it would be much appreciated.

Server logfile:
Code: Select all
2016-Jan-17 18:56:16:   
2016-Jan-17 18:56:16:   ==============================================================
2016-Jan-17 18:56:16:                      Logging is started
2016-Jan-17 18:56:16:   ==============================================================
2016-Jan-17 18:56:21:   [I] DVBLink server product id: 5fec3295-a38f-11e3-a88c-005056c00008
2016-Jan-17 18:56:25:   [I] ---------------------------
2016-Jan-17 18:56:25:   [I] Installed DVBLink products:
2016-Jan-17 18:56:25:   [I] DVBLink Server, 5.5.0, 12217
2016-Jan-17 18:56:25:   [I] DVBLink TVSource, 5.5.0, 12217
2016-Jan-17 18:56:25:   [I] ---------------------------




Webserver logfile:
Code: Select all
[17/Jan/2016:18:56:30] DVB.CMN.AUTH Authorization False
[17/Jan/2016:18:56:30] DVB.CMN.BL Create domain ('common', 'C:\\Program Files\\DVBLogic\\DVBLink\\web_server\\common\\..\\locale', u'en', <gettext.GNUTranslations instance at 0x157068F0>).
[17/Jan/2016:18:56:30] DVB.CMN.SR Warning: not found configurator for MC Guide Services.
[17/Jan/2016:18:56:30] DVB.CMN.BL Create domain ('tvsource', 'C:\\Program Files\\DVBLogic\\DVBLink\\web_server\\common\\..\\locale', u'en', <gettext.GNUTranslations instance at 0x15589EE0>).
[17/Jan/2016:18:56:30] DVB.CMN.SR Add configurator for TVSource.
[17/Jan/2016:18:56:30] DVB.CMN.BL Create domain ('xmltv', 'C:\\Program Files\\DVBLogic\\DVBLink\\web_server\\common\\..\\locale', u'en', <gettext.GNUTranslations instance at 0x156A0210>).
[17/Jan/2016:18:56:30] DVB.CMN.SR Add configurator for XMLTV.
[17/Jan/2016:18:56:30] DVB.CMN.SA Search addons in: "C:\Program Files\DVBLogic\DVBLink\web_server\addons".
[17/Jan/2016:18:56:30] DVB.CMN.BL Create domain ('connect', 'C:\\Program Files\\DVBLogic\\DVBLink\\web_server\\common\\..\\locale', u'en', <gettext.GNUTranslations instance at 0x156D21C0>).
[17/Jan/2016:18:56:30] DVB.CMN.SA Added connect_server, "0.0.0.0:8100".
[17/Jan/2016:18:56:30] ENGINE Bus STARTING
[17/Jan/2016:18:56:30] ENGINE Started monitor thread '_TimeoutMonitor'.
[17/Jan/2016:18:56:35] ENGINE Error in 'start' listener <bound method ServerAdapter.start of <cherrypy.process.servers.ServerAdapter object at 0x1575FC90>>
Traceback (most recent call last):
  File "C:\Program Files\DVBLogic\DVBLink\web_server\lib.zip\cherrypy\process\wspbus.py", line 179, in publish
    output.append(listener(*args, **kwargs))
  File "C:\Program Files\DVBLogic\DVBLink\web_server\lib.zip\cherrypy\process\servers.py", line 167, in start
    wait_for_free_port(*self.bind_addr)
  File "C:\Program Files\DVBLogic\DVBLink\web_server\lib.zip\cherrypy\process\servers.py", line 403, in wait_for_free_port
    raise IOError("Port %r not free on %r" % (port, host))
IOError: Port 8100 not free on '0.0.0.0'

[17/Jan/2016:18:56:35] ENGINE Serving on 0.0.0.0:39876
[17/Jan/2016:18:56:35] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
  File "C:\Program Files\DVBLogic\DVBLink\web_server\lib.zip\cherrypy\process\wspbus.py", line 216, in start
    self.publish('start')
  File "C:\Program Files\DVBLogic\DVBLink\web_server\lib.zip\cherrypy\process\wspbus.py", line 196, in publish
    raise exc
ChannelFailures: IOError("Port 8100 not free on '0.0.0.0'",)

[17/Jan/2016:18:56:35] ENGINE Bus STOPPING
[17/Jan/2016:18:56:35] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('0.0.0.0', 39876)) shut down
[17/Jan/2016:18:56:35] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('0.0.0.0', 8100)) already shut down
[17/Jan/2016:18:56:35] ENGINE Stopped thread '_TimeoutMonitor'.
[17/Jan/2016:18:56:35] ENGINE Bus STOPPED
[17/Jan/2016:18:56:35] ENGINE Bus EXITING
[17/Jan/2016:18:56:35] ENGINE Bus EXITED

SORCERER
 
Posts: 6
Joined: Tue Oct 13, 2015 7:10 pm


Re: Server stops a few seconds after starting.

Postby Oberon » Sun Jan 17, 2016 8:10 pm

To investigate your issue we would need additional information from you.

Please set log level to info, restart DVBLink server, reproduce the issue, download and attach zipped DVBLink log files to this topic.
Oberon
 
Posts: 11718
Joined: Thu Sep 06, 2007 5:04 am

Re: Server stops a few seconds after starting.

Postby SORCERER » Sun Jan 17, 2016 10:13 pm

Ok. Is there a way to change the log level manually, since I can't reach the web interface.
SORCERER
 
Posts: 6
Joined: Tue Oct 13, 2015 7:10 pm

Re: Server stops a few seconds after starting.

Postby Oberon » Sun Jan 17, 2016 10:30 pm

Most probably some other software uses ports 8100 or 39876 on your system. Can you check if it so, please?
Oberon
 
Posts: 11718
Joined: Thu Sep 06, 2007 5:04 am

Re: Server stops a few seconds after starting.

Postby SORCERER » Sun Jan 17, 2016 11:55 pm

Did a port scan that returned the following:

Port 8100 (TCP) CherryPy httpd 3.2.0
Port 8101 (TCP)

Port 39876 (TCP) CherryPy httpd 3.2.0
Port 39877 (TCP)
Port 39879 (TCP)
Port 39880 (TCP)
Port 39881 (TCP)
SORCERER
 
Posts: 6
Joined: Tue Oct 13, 2015 7:10 pm

Re: Server stops a few seconds after starting.

Postby SORCERER » Mon Jan 18, 2016 10:44 pm

Hi Oberon

I upgraded server to 12340 and managed to set log level to info before it shut down again.

I have attached the zipped log files as you asked for.

DVBLog.zip
Server log files
(7.59 KiB) Downloaded 45 times
SORCERER
 
Posts: 6
Joined: Tue Oct 13, 2015 7:10 pm

Re: Server stops a few seconds after starting.

Postby the_man » Tue Jan 19, 2016 11:59 am

Can you please, try next test:
- be sure that the server is stopped
- go to C:\Users\Public\Documents\DVBLink (there should be the dlrecorder.db file)
- make a backup of this file (just rename it to back_dlrecorder.db )
- start the server
- Whether the behaviour is repeated?
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4664
Joined: Mon Dec 02, 2013 1:11 pm

Re: Server stops a few seconds after starting.

Postby SORCERER » Wed Jan 20, 2016 6:05 pm

Did as you said, but with the same result.

Det Dvblink service is set to restart if failing, so I attached new log files with a few restarts.

Hope you guys can find something there that makes sense.
Attachments
Log 200116.zip
(24.34 KiB) Downloaded 45 times
SORCERER
 
Posts: 6
Joined: Tue Oct 13, 2015 7:10 pm

Re: Server stops a few seconds after starting.

Postby the_man » Thu Jan 21, 2016 10:32 am

Can we make a teamviewer session? I'd like to have a look at the issue with my own eyes. All private data, please, send to the PM on this forum.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4664
Joined: Mon Dec 02, 2013 1:11 pm

Re: Server stops a few seconds after starting.

Postby stoeckie » Fri Dec 22, 2017 9:53 pm

I've got the same problem. What was the solution?
stoeckie
 
Posts: 1
Joined: Fri Dec 22, 2017 9:50 pm


Return to DVBLink Server on Windows platform

Who is online

Users browsing this forum: No registered users and 2 guests