DLNA problems

Post your questions about DVBLink products running on Windows platform here!

DLNA problems

Postby mtandrup » Fri Sep 18, 2015 4:40 pm

Hi again

I'm having alot of problems with the DLNA server.

When I restart the server machine, the DLNA server usually works, but after a short while, I'm unable to find the DLNA server on DLNA clients.
If I restart the server machine, the DLNA server again works, but only for a short while.

I haven't been able to spot anything unusual in the logs.

I also seem to be having some issues with stopping/starting and restarting the DVBLink service (it often doesn't respond to the request using the Windows Services window).
Could this be related to the DLNA problem?

Help please.
Attachments
dvblink-log-20150918-1740.zip
(86.68 KiB) Downloaded 131 times
Best regards
Michael Tandrup
Denmark
mtandrup
 
Posts: 29
Joined: Wed Jul 29, 2015 2:09 pm


Re: DLNA problems

Postby the_man » Fri Sep 18, 2015 5:08 pm

May be you have done some tests, but at your log files are present several times next strings:
Code: Select all
[I] sink_manager::load_mod(): Loading module "dlna_server"
[E] sink_base::sink_base(): Sink "dlna_server" (path: C:\Program Files (x86)\DVBLogic\DVBLink\sinks\dlna_server\dlna_server.dll) was not found
[I] sink_base::~sink_base(): Unloading sink "dlna_server", module "dlna_server.dll"
[E] sink_manager::load_mod(): module "dlna_server" not loaded
[I] sink_manager::load_mod(): Loading module "dlrecorder"


But with the latest restart of dvblink server all looks good.
Maybe you have an antivirus which leads to such behavior... Or maybe it's just conflicts with some other software.
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: DLNA problems

Postby mtandrup » Fri Sep 18, 2015 5:19 pm

Those lines are there because I was trying out some things.
One of them was renaming the dlna_server.dll file.

I'm running Windows 10 with builtin Firewall and antivirus.

You may be right, when suggesting that the DLNA server conflicts with other software.
I just can't figure out, what it might be.

I have also looked through the Windows logs, but again I'm not able to find exactly where the problem occurs.

Other suggestions?
Best regards
Michael Tandrup
Denmark
mtandrup
 
Posts: 29
Joined: Wed Jul 29, 2015 2:09 pm

Re: DLNA problems

Postby Muppets4 » Sun Sep 20, 2015 3:19 pm

Just to let you know you are not the only one with this problem. Just upgraded from 4.6 to 5.5 today. DLNA server is no where to be seen.
HDHomerun 4 channel tuner
Muppets4
 
Posts: 109
Joined: Sun Feb 05, 2012 11:15 am

Re: DLNA problems

Postby mtandrup » Mon Sep 21, 2015 12:11 pm

I'm not sure my problem is related to your problem.

My primary problem right now, is actually that the DVBLink service often won't start/stop/restart.

Once it's started though, everything seems to work fine - except for DLNA.

I don't have a clue as to what the problem is.
None of the logs show anything wrong.

I may have to just do a complete reinstall of this PC.
Maybe I just messed around too much with DVBLink, OpenVPN, IIS, MySQL etc.
Best regards
Michael Tandrup
Denmark
mtandrup
 
Posts: 29
Joined: Wed Jul 29, 2015 2:09 pm

Re: DLNA problems

Postby Muppets4 » Mon Sep 21, 2015 6:00 pm

mtandrup wrote:I'm not sure my problem is related to your problem.

My primary problem right now, is actually that the DVBLink service often won't start/stop/restart.

Once it's started though, everything seems to work fine - except for DLNA.

I don't have a clue as to what the problem is.
None of the logs show anything wrong.

I may have to just do a complete reinstall of this PC.
Maybe I just messed around too much with DVBLink, OpenVPN, IIS, MySQL etc.


I used to have a DLNA server in Windows Media Player, but now there is not. When playing with all those you mentioned you could have broken something.
HDHomerun 4 channel tuner
Muppets4
 
Posts: 109
Joined: Sun Feb 05, 2012 11:15 am

Re: DLNA problems

Postby the_man » Tue Sep 22, 2015 9:04 am

Just to confirm that at dvblink side all works correctly. I have nearly ten servers and i can see all of them (i mean DLNA) at any of my devices at the local network ( android/ios devices, win7/win8 PC's, sony tv)
NETGEAR RNDU2000; Synology DS112j, DS 212j, DS213+, DS 712+; Western Digital WD ex2; Asustor AS3, RPI2 ...
PCTV 460,461e,292e; TT 4400, 4650CI;DVBSKy S960; DD octopus net; Inverto sat2ip multibox; TBS DVB-C ...
the_man
 
Posts: 4696
Joined: Mon Dec 02, 2013 1:11 pm

Re: DLNA problems

Postby mtandrup » Tue Sep 22, 2015 6:40 pm

the_man wrote:Just to confirm that at dvblink side all works correctly. I have nearly ten servers and i can see all of them (i mean DLNA) at any of my devices at the local network ( android/ios devices, win7/win8 PC's, sony tv)


I understand.

It just nags me, that I'm unable to find the cause of the problem.
Usually there's some kind of indication, but in this case nothing.

I have looked through port scan results, firewall settings, network setting, logs etc.

But I will do a reinstall in the near future - it's not that big of a deal - and report back.
Best regards
Michael Tandrup
Denmark
mtandrup
 
Posts: 29
Joined: Wed Jul 29, 2015 2:09 pm

Re: DLNA problems

Postby mtandrup » Sun Oct 04, 2015 12:01 pm

So I just did a complete reinstall.

IIS webserver and OpenVPN is up and running again, and so is DVBLink.
I have not restored anything from backups.

So far the DLNA server seems to be stable.
It doesn't always show up right away on the client. Sometimes a few seconds is needed before it appears.
But I guess this is normal behavior.

So as of now a reinstall of the PC seems to have helped.
Best regards
Michael Tandrup
Denmark
mtandrup
 
Posts: 29
Joined: Wed Jul 29, 2015 2:09 pm


Return to DVBLink Server on Windows platform

Who is online

Users browsing this forum: No registered users and 1 guest

cron