Problem recording with Windows MCE

Post your questions about DVBLink products running on Windows platform here!

Problem recording with Windows MCE

Postby Bjorn64 » Mon Jan 26, 2015 4:48 pm

Hi,

I am testing DVBlink on a PC with an external Tuner (USB) and have problems with scheldued recordings in Media Center.

Setup:

Windows 8.1 (X64) with Media Center
Technotrend CT2-4650 with CI (CAM with card). Driver version: 4.1.0.1
Latest DVBlink Server and TV Source versions, 5.1.0 build 11030

I can look and make direct recordings of the channels in Media Center.
But scheldued recordings fail normally, both with PC on and after wake up.
After when I go into a channel in MCE I got a messages “Sorry cannot display this channel either because there is a technical problem or no TV signal” with DVB logic logo.
After when I try to configure TV-Source I got message about recording ongoing…
It seems that either Server or TV-source have crashed. Also the tuner card.
I reboot, but the problem remains. I have to reset the tuner to get it working.

Server log (shows a number fail recordings):

2015-Jan-26 11:23:04: [I] DVBLink server product id: 5fec3295-a38f-11e3-a88c-005056c00008
2015-Jan-26 11:23:05: [W] broker::start_recorder(): recorder is not found!!!
2015-Jan-26 11:28:35: [W] bst_ci_control: KSPROPERTY_BDA_BSTCI_IOCTL, SET failed
2015-Jan-26 11:28:35: [E] property_set_ci_send_pmt()
2015-Jan-26 11:31:43: [W] bst_ci_control: KSPROPERTY_BDA_BSTCI_IOCTL, SET failed
2015-Jan-26 11:31:43: [E] property_set_ci_send_pmt()
2015-Jan-26 11:50:13: [W] bst_ci_control: KSPROPERTY_BDA_BSTCI_IOCTL, SET failed
2015-Jan-26 11:50:13: [E] property_set_ci_send_pmt()
2015-Jan-26 11:53:45: [W] bst_ci_control: KSPROPERTY_BDA_BSTCI_IOCTL, SET failed
2015-Jan-26 11:53:45: [E] property_set_ci_send_pmt()
2015-Jan-26 12:02:00: [W] bst_ci_control: KSPROPERTY_BDA_BSTCI_IOCTL, SET failed
2015-Jan-26 12:02:00: [E] property_set_ci_send_pmt()
2015-Jan-26 12:09:06: [W] Cannot start graph, -2147024865
2015-Jan-26 12:13:06: [W] Cannot start graph, -2147024865
2015-Jan-26 12:19:10: [W] Cannot start graph, -2147024865
2015-Jan-26 12:27:29: [W] Cannot start graph, -2147024865
2015-Jan-26 12:46:00: [E] stream_manager::::add_stream_to_source. Switching to channel 11960000 of source f7565be4-0814-43b1-ba56-c6a8d76059aa failed.
2015-Jan-26 12:59:00: [E] stream_manager::::add_stream_to_source. Switching to channel 11960000 of source f7565be4-0814-43b1-ba56-c6a8d76059aa failed.

Is this problem caused by in the DVBlink SW, Windows, the Driver for CT2-4650 or is it something with the local setup?
Any ideas?

Best Regards
Bjorn64
 
Posts: 15
Joined: Mon Jan 26, 2015 2:01 pm


Re: Problem recording with Windows MCE

Postby Oberon » Mon Jan 26, 2015 5:28 pm

Error -2147024865 means that "A device attached to the system is not functioning". I would say it is driver fault. We also have a comparable report from another user who is using TT tuners. I do not know at the moment if we can do anything to fix it.
Oberon
 
Posts: 11763
Joined: Thu Sep 06, 2007 5:04 am

Re: Problem recording with Windows MCE

Postby Bjorn64 » Mon Jan 26, 2015 11:57 pm

The thing is that sometimes recoding work and with DVBviewer I don't have this problem.
Could this be a signal issue? The signal strength 60-65% and quality is 100%. It should be ok?
Furthermore I use SmartWi to distribute the encoded information from a master card to receiver boards in each unit.
Sometimes it's problem with this, maybe it could be this.
I have also seen message about low signal in MCE.
Does it make sense?
How should the TV-Source best be configured for DVB-C?

BR
Bjorn64
 
Posts: 15
Joined: Mon Jan 26, 2015 2:01 pm

Re: Problem recording with Windows MCE

Postby holzfred » Tue Jan 27, 2015 7:29 am

Hello,

A friend of me have the same problem, is it possible that dvblink start the service much faster than USB do? Because the fault is gone after a stop/restart from the service. His fault is only after wake up from s3s4.

He fixed it with an entry in bios... USB full initialisation - not automatic..

Maybe it helps.


Via tapatalk
holzfred
 
Posts: 134
Joined: Sun Apr 28, 2013 11:35 am

Re: Problem recording with Windows MCE

Postby Oberon » Tue Jan 27, 2015 9:12 am

Adding the delay is easy.
Stop dvblink server and add the key sources_start_after_standby_delay_s to the root of dvblink_configuration.xml. For example for delay of 10 seconds:
Code: Select all
<sources_start_after_standby_delay_s>10</sources_start_after_standby_delay_s>

By default delay is 5 sec.
Oberon
 
Posts: 11763
Joined: Thu Sep 06, 2007 5:04 am

Re: Problem recording with Windows MCE

Postby Bjorn64 » Tue Jan 27, 2015 3:26 pm

Strange, you answered a question I planned to write here :-), telepahty?

Anyway, I changed the Cable Connection for DVB-C to another coonnector in the house and got a bit higher signal strength (60->65%).
Then I set a number of scheldued recordings and none failed. I changed to connect through a splitter, signal strength went down to 60% and the problems started again.
My conclusion was that it could be a time out issue connected to the signal strength and to change the time out may help.
My question would be, where to change it and as I wrote above you have already answered it.
I will try and see if it helps...

In the TV-Source box there is a small box with a colour, here it has a ways been red or near red, have not seen any explanation of this, but I guess it's signal indicator?

Another thing to think about is why the signal strength is only 60-65%, when the TV sets shows over 90% or more with the same source!? Not correct?
DVB Viewer shows the same stremgth as TV-Source, so 60-65% it should be ok?

BR
Bjorn64
 
Posts: 15
Joined: Mon Jan 26, 2015 2:01 pm

Re: Problem recording with Windows MCE

Postby Bjorn64 » Wed Jan 28, 2015 11:00 am

Changing the delay made the trick. Tried with 10s first, but it was not stable, changed to 20s and it seems ok now.
It seems that the problem is solved, thank's for support!

So TT-CT2-4650 CI is then working to 100% with DVBlink, time to register the SW...

BR/Björn
Bjorn64
 
Posts: 15
Joined: Mon Jan 26, 2015 2:01 pm


Return to DVBLink Server on Windows platform

Who is online

Users browsing this forum: No registered users and 1 guest

cron