Frequently no sound in tvOS and iOS

General discussion about DVBLink clients

Frequently no sound in tvOS and iOS

Postby andythomnz » Wed Sep 27, 2017 10:11 am

Hi,
I am using the server with IPTV.
When using the iOS client or the AppleTV client, there is often no sound when opening a stream (but video streams smoothly).
I have never had this problem on any other clients I use: Android, Mac OS, Windows, Kodi.

I read somewhere that maybe it is due to the audio codec, however I think this is not the case. Usually if I force close and reopen the app enough times, it will eventually stream audio. So I don't think the audio stream could be incompatible.

I also read somewhere that it could be due to the audio-codec changing between commercial break and actual tv program. But this also isn't the case - it happens during the same show.

Anyone else experiencing this? Any help would be greatly appreciated :D
andythomnz
 
Posts: 2
Joined: Wed Sep 27, 2017 9:56 am


Re: Frequently no sound in tvOS and iOS

Postby Montoya » Wed Sep 27, 2017 1:08 pm

Try MrMC for the Apple TV and see what happens there with the sound.

MrMC has similar interface as Kodi (if you don't already use Kodi on your Apple TV) and also has the DVBLink PVR addon available in its app.
Just as in Kodi, you can select an audio stream if the iptv stream has multiple.
DVBLink server 6.0.0 build14499, DVBLink TVSource 6.0.0 build14061, DVBLink for IPTV build 13107
Kodi 18.0-ALPHA1 Git:20180125-7379a75, Win10 Pro x64 1709 build16299.125
Montoya
 
Posts: 134
Joined: Fri Apr 29, 2016 6:06 pm

Re: Frequently no sound in tvOS and iOS

Postby andythomnz » Fri Sep 29, 2017 6:35 am

Thanks for that suggestion.

Tried MrMC on my iPad - all good. Works fairly well, and no issues with sound.
Although I couldn't see how to access the TV guide or schedule recordings? Is that maybe not available on the light version...?
Nor could I see where to access TV recordings. Live TV really seemed to be the only option.

Also tried it on my Apple TV. Wouldn't play any live-streams...
When you clicked on a channel, the loading/buffering circles would come up for a few seconds, and then it would just return to the channel list. (And, no, it wasn't playing in the background).
Thought that was strange, seeing it worked fine on my iPad.

Downloaded the official Kodi for Apple TV, opened it in Xcode, signed the app using my Apple developer account, and installed it on the Apple TV using a USB cable. Eventually got Kodi working.
Setup the DVBLink Add-on, and it did exactly the same thing as MrMC did on the Apple TV. Very very strange.

Anyone have any thoughts?
andythomnz
 
Posts: 2
Joined: Wed Sep 27, 2017 9:56 am

Re: Frequently no sound in tvOS and iOS

Postby Montoya » Fri Sep 29, 2017 11:43 am

Have you set up the PVR addon correctly in MrMC and Kodi ?
And in system settings audio output, have you checked your settings there ?

When you press TV in MrMC, you get channel list. Swipe left for more options like accessing guide, recordings etc.
Looks like you are unfamiliar with Kodi, so watch some Youtube guides to get familiar with Kodi and MrMC.

If you are used to Kodi 16, change skin to Amber in MrMC.

MrMC worked right out of the box for me with DVBLink PVR addon in MrMC, with same settings I used for my Kodi on my HTPC.
DVBLink server 6.0.0 build14499, DVBLink TVSource 6.0.0 build14061, DVBLink for IPTV build 13107
Kodi 18.0-ALPHA1 Git:20180125-7379a75, Win10 Pro x64 1709 build16299.125
Montoya
 
Posts: 134
Joined: Fri Apr 29, 2016 6:06 pm


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest